summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2022-12-19 19:11:53 +0100
committerAlexBocken2022-12-19 19:11:53 +0100
commit741141c1124289edf23aafb118ece4fbfdb63ce5 (patch)
treee1e07d021f9d55bed97368d315a2b9b233c054d2
parent28f12b9af4e5f7dd6051d74ad4ba6c56ee0c455c (diff)
downloadaur-741141c1124289edf23aafb118ece4fbfdb63ce5.tar.gz
add nodejs and !lto to finally build in clean chroot
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96949c0cf6f9..437bcf48d2d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anki
pkgdesc = Helps you remember facts (like words/phrases in a foreign language) efficiently
pkgver = 2.1.55
- pkgrel = 6
+ pkgrel = 7
url = https://apps.ankiweb.net/
arch = x86_64
license = AGPL3
@@ -11,8 +11,8 @@ pkgbase = anki
makedepends = cargo
makedepends = python-installer
makedepends = libxcrypt-compat
+ makedepends = nodejs
depends = python-beautifulsoup4
- depends = python-flask
depends = python-waitress
depends = python-decorator
depends = python-markdown
@@ -36,6 +36,7 @@ pkgbase = anki
conflicts = anki-official-binary-bundle
conflicts = anki-qt5
options = !ccache
+ options = !lto
source = anki-2.1.55::git+https://github.com/ankitects/anki#tag=2.1.55
source = no-update.patch
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8232a9756aec..95ee7b955dfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,18 +9,17 @@
pkgname=anki
pkgver=2.1.55
-pkgrel=6
+pkgrel=7
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
url="https://apps.ankiweb.net/"
license=('AGPL3')
arch=('x86_64')
provides=('anki')
conflicts=('anki-bin' 'anki-git' 'anki-official-binary-bundle' 'anki-qt5')
-options=('!ccache')
+options=('!ccache' '!lto')
depends=(
# anki & aqt
'python-beautifulsoup4'
- 'python-flask'
'python-waitress'
# anki
@@ -32,7 +31,7 @@ depends=(
'python-distro'
#aqt
- 'python-flask-cors'
+ 'python-flask-cors' # python-flask required for anki & aqt but a dependency of -cors
'python-jsonschema'
'python-requests'
'python-send2trash'
@@ -43,11 +42,11 @@ depends=(
makedepends=(
'rsync'
'git'
-
'ninja'
'cargo'
'python-installer'
'libxcrypt-compat'
+ 'nodejs'
)
optdepends=(
'lame: record sound'