summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-05-16 09:45:08 +0200
committerAlexBocken2023-05-16 09:45:08 +0200
commit8d4e64f828c1972192df041cc2e2046f80704c61 (patch)
tree8232f6ec4b87e2b311610ec6577ea51d41b82f9a
parenta322ee0a6607dbf25acca660a45bfaa5171905ba (diff)
downloadaur-8d4e64f828c1972192df041cc2e2046f80704c61.tar.gz
use `which` to get python and protoc bins
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d78fbe81e854..794ce86628c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -79,9 +79,9 @@ build() {
cd "$pkgname"
#use local binaries instead of downloading them as well for python and protoc
- export PYTHON_BINARY=$(type python | cut -d' ' -f1,2 --complement)
- export PROTOC_BINARY=$(type protoc | cut -d' ' -f1,2 --complement)
- #export NODE_BINARY=$(type node | cut -d' ' -f1,2 --complement) # does not yet compile
+ export PYTHON_BINARY=$(which python)
+ export PROTOC_BINARY=$(which protoc)
+ #export NODE_BINARY=$(which node) # does not yet compile
./tools/build
}