summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexBocken2023-04-02 14:17:31 +0200
committerAlexBocken2023-04-02 14:17:31 +0200
commitd2b02b365476b035df735d9d9afd2f478aa19b06 (patch)
tree54f28c4a4cb1c04129f139a2d81d4769a373b321
parent591fb825d477cef651fe115f1f4367bd2bfaab5b (diff)
downloadaur-d2b02b365476b035df735d9d9afd2f478aa19b06.tar.gz
add pgp key, move to tag commit hash
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d32b78c710c8..20cd176417bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -40,8 +40,9 @@ pkgbase = anki
conflicts = anki-qt5
conflicts = anki-qt5-debug
options = !lto
- source = anki::git+https://github.com/ankitects/anki#tag=2.1.61
+ source = anki::git+https://github.com/ankitects/anki#tag=00556663989832a51b24da237ef3be77677c1bb6?signed
source = no-update.patch
+ validpgpkeys = 814EA4E90C34AF39A712DE703F5566A2D16899FB
sha256sums = SKIP
sha256sums = 137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797
diff --git a/PKGBUILD b/PKGBUILD
index ac15bebbd9b9..0fb16e23f7bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,7 @@
pkgname=anki
pkgver=2.1.61
+_tag=00556663989832a51b24da237ef3be77677c1bb6 #git rev-parse $pkgver
pkgrel=1
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
url="https://apps.ankiweb.net/"
@@ -57,25 +58,34 @@ optdepends=(
)
# using the tag tarballs does not work with the new (>= 2.1.55) build process.
# the '.git' folder is not included in those but is required for a sucessful build
-source=("anki::git+https://github.com/ankitects/anki#tag=${pkgver}"
+source=("$pkgname::git+https://github.com/ankitects/anki#tag=${_tag}?signed"
"no-update.patch"
)
sha256sums=('SKIP'
'137827586d2a72adddaaf98599afa9fc80cdd73492d7f5cbcf4d2f6082e5f797'
)
+validpgpkeys=(
+ 814EA4E90C34AF39A712DE703F5566A2D16899FB # Anki Signatures <gpg@ankiweb.net>
+)
+
prepare(){
- cd "anki"
+ cd "$pkgname"
# pro-actively prevent "module not found" error (TODO: verify whether still required)
[ -d ts/node_modules ] && rm -r ts/node_modules
patch -p1 < "$srcdir/no-update.patch"
}
build() {
- cd "anki"
+ cd "$pkgname"
./tools/build
}
+pkgver(){
+ cd "$pkgname"
+ git describe
+}
+
package() {
cd "anki"
for file in out/wheels/*.whl; do