summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSami Boukortt2015-06-27 13:39:26 +0200
committerSami Boukortt2015-06-27 13:40:50 +0200
commit1a435a04132f467300cb4095e6e10e33cf036f61 (patch)
treea17c300b529c6281d7aa6d4e1d5b96fda3a220b4
downloadaur-1a435a04132f467300cb4095e6e10e33cf036f61.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD47
-rw-r--r--cmake.patch13
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e10fbedf4e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = composer-git
+ pkgdesc = Song editor for karaoke games
+ pkgver = 2.0rc1.8.g42f058a
+ pkgrel = 1
+ epoch = 1
+ url = http://performous.org/composer
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-multimedia
+ depends = ffmpeg
+ provides = composer
+ conflicts = composer
+ source = cmake.patch
+ source = git+https://github.com/performous/composer.git
+ sha512sums = b9327a41bfb1e80eadf2bb64a937fc283414b897450925f981256ffcf6967aa845860eb40a683c523d8e71a426d77027d6abf7be85218657705c888ffea55406
+ sha512sums = 814f22ec5c640ea4f23fc1dad192cc3393632aa544e20c6f35d6d6963dbbc711b9b68433da0fcebcd91611947824978c6edfb6bcb2053601447dc32d7f32d74c
+ sha512sums = SKIP
+
+pkgname = composer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02695aae07a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+pkgname=composer-git
+pkgver=2.0rc1.8.g42f058a
+epoch=1
+pkgrel=1
+pkgdesc="Song editor for karaoke games"
+arch=(i686 x86_64)
+url="http://performous.org/composer"
+license=(GPL)
+depends=(qt5-multimedia ffmpeg)
+makedepends=(git cmake)
+provides=(composer)
+conflicts=(composer)
+source=(cmake.patch
+ git+https://github.com/performous/composer.git)
+sha512sums=(b9327a41bfb1e80eadf2bb64a937fc283414b897450925f981256ffcf6967aa845860eb40a683c523d8e71a426d77027d6abf7be85218657705c888ffea55406
+ 814f22ec5c640ea4f23fc1dad192cc3393632aa544e20c6f35d6d6963dbbc711b9b68433da0fcebcd91611947824978c6edfb6bcb2053601447dc32d7f32d74c
+ SKIP)
+
+pkgver() {
+ cd composer
+ git describe --tags | tr - .
+}
+
+prepare() {
+ cd composer
+
+ git apply --3way "$srcdir/cmake.patch"
+}
+
+build() {
+ mkdir composer/build
+ cd composer/build
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ ..
+ make
+}
+
+package() {
+ cd composer/build
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cmake.patch b/cmake.patch
new file mode 100644
index 000000000000..ef13ff619f7e
--- /dev/null
+++ b/cmake.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6a8e107..d789ae5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,8 +23,6 @@ endif(NOT CMAKE_BUILD_TYPE)
+
+ # Find includes in corresponding build directories
+ set(CMAKE_INCLUDE_CURRENT_DIR ON)
+-# Instruct CMake to run moc automatically when needed.
+-set(CMAKE_AUTOMOC ON)
+
+ # Find all the libs that don't require extra parameters
+ foreach(lib AVFormat Qt5Core Qt5Widgets Qt5Gui Qt5Xml Qt5Multimedia)