summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaszlo Gombos2024-03-03 20:10:06 -0500
committerLaszlo Gombos2024-03-03 20:10:06 -0500
commit5f0142772c403f89ee93f14c65ca8a9a3307dc0f (patch)
tree5dc55ec72aa587f98124eeb0d9cc23e5814ef851
parent4faa9b5610d5da37f2f9825a1947d5fc58db26cc (diff)
downloadaur-5f0142772c403f89ee93f14c65ca8a9a3307dc0f.tar.gz
set KVERSION for check
-rw-r--r--Dockerfile4
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 3 deletions
diff --git a/Dockerfile b/Dockerfile
index 030bffeef28c..a62c9df5fe9c 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -11,12 +11,12 @@ RUN su build -c 'cd && git clone https://aur.archlinux.org/paru-bin.git && cd pa
RUN su build -c 'paru --needed --noconfirm -Syu perl-config-general tgt'
# install dracut-git without running tests
-RUN su build -c 'paru --nocheck --needed --noconfirm -Syu dracut-git'
+RUN su build -c 'paru --needed --noconfirm -Syu dracut-git'
# install all optional dependencies
RUN L=$(paru -Si dracut-git | sed -n '/^Opt/,/^Conf/p' | sed '$d' | sed 's/^Opt.*://g' | sed 's/^\s*//g' | tr '\n' ' ') && su build -c "paru --needed --noconfirm -Syu $L"
# reinstall with running tests
-RUN su build -c 'V=1 paru --rebuild -S dracut-git'
+#RUN su build -c 'V=1 KVERSION="$(cd /lib/modules ls -1 | tail -1)" TESTS="30" SKIP=" " paru --rebuild -S dracut-git'
RUN rm -fr ~build
diff --git a/PKGBUILD b/PKGBUILD
index 38464ec40fb1..97579b495d15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -179,7 +179,7 @@ build() {
check() {
cd "${pkgname%-git}/test"
- SKIP=${SKIP-"20 30 35 40 50 60 62 63"} TESTS=${TESTS-"18"} make check
+ SKIP=${SKIP-"20 30 35 40 50 60 62 63"} TESTS=${TESTS-"18"} KVERSION="$(cd /lib/modules && ls -1 | tail -1)" make check
}
package() {