summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaszlo Gombos2024-03-03 22:19:08 -0500
committerLaszlo Gombos2024-03-03 22:19:08 -0500
commite6b593081b4eb82cb374e26ec1e26a7d2040f6ce (patch)
tree12e7d96c44bcbee98b61d1b832d0fd4289060ec5
parent171ba7ed71b71dce1136aea4fa303a39f346ab12 (diff)
downloadaur-e6b593081b4eb82cb374e26ec1e26a7d2040f6ce.tar.gz
unskip test 35 as it is passing now
-rw-r--r--Dockerfile10
-rw-r--r--PKGBUILD2
2 files changed, 5 insertions, 7 deletions
diff --git a/Dockerfile b/Dockerfile
index b3048f721e11..d8056854f75d 100644
--- a/Dockerfile
+++ b/Dockerfile
@@ -7,16 +7,14 @@ RUN pacman --noconfirm -Syu base-devel git pacman-contrib
RUN useradd -m build && echo "build ALL=(ALL) NOPASSWD: /usr/bin/pacman" >> "/etc/sudoers.d/allow_pacman" && echo "build ALL=(ALL) NOPASSWD: /usr/bin/paru" >> "/etc/sudoers.d/allow_pacman"
RUN su build -c 'cd && git clone https://aur.archlinux.org/paru-bin.git && cd paru-bin && makepkg -s --noconfirm' && pacman -U --noconfirm ~build/paru-bin/*.pkg.tar.*
-# AUR test dependencies
-RUN su build -c 'paru --needed --noconfirm -Syu tgt'
-
# install dracut-git without running tests
RUN su build -c 'paru --nocheck --needed --noconfirm -Syu dracut-git'
# install all optional dependencies
RUN L=$(paru -Si dracut-git | sed -n '/^Opt/,/^Conf/p' | sed '$d' | sed 's/^Opt.*://g' | sed 's/^\s*//g' | tr '\n' ' ') && su build -c "paru --needed --noconfirm -Syu $L"
-# reinstall to run tests
-RUN su build -c 'V=1 TESTS=30 SKIP="18" paru --rebuild -S dracut-git'
+# AUR test dependencies
+RUN su build -c 'paru --needed --noconfirm -Syu tgt'
-RUN rm -fr ~build
+# rebuild to run some tests
+RUN su build -c 'cd ~build/.cache/paru/clone/dracut-git && V=1 TESTS=18 makepkg --force --syncdeps --noconfirm'
diff --git a/PKGBUILD b/PKGBUILD
index 9ee4c83864fd..b0e2b1c8a4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -180,7 +180,7 @@ build() {
check() {
cd "${pkgname%-git}/test"
- SKIP=${SKIP-"20 35 40 50 60 62 63"} TESTS=${TESTS-"18"} KVERSION="$(cd /lib/modules && ls -1 | tail -1)" make check
+ SKIP=${SKIP-"20 40 50 60 62 63"} TESTS=${TESTS-"18"} KVERSION="$(cd /lib/modules && ls -1 | tail -1)" make check
}
package() {