summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2021-09-07 11:37:03 +0800
committerAllen Zhong2021-09-07 11:47:00 +0800
commit2c6a842f0b22cb279f254fdc7b598101155550d4 (patch)
tree435a2aad4bbc1bd6801ea28e453e8d9ee677ff45
parent57adf990a064441ea2f17ee46494937226da0678 (diff)
downloadaur-2c6a842f0b22cb279f254fdc7b598101155550d4.tar.gz
bump v4.8.0-beta24
it's finally released and can be publically downloaded
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD19
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 892d47629216..dcd82491ae08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = feishu-bin
pkgdesc = Linux client of Feishu (Lark) from Bytedance.
- pkgver = 4.3.0
+ pkgver = 4.8.0
pkgrel = 1
url = https://www.feishu.cn/
install = feishu-bin.install
@@ -14,10 +14,12 @@ pkgbase = feishu-bin
depends = nss
depends = xdg-utils
provides = bytedance-feishu
+ provides = feishu
+ conflicts = feishu
replaces = bytedance-feishu-stable-bin
options = !strip
options = !emptydirs
- source = file://bytedance-feishu_4.3.0-49_amd64.deb
- sha256sums = fbd28428ec3df298a03b7bf61d140b8533b16b4506e7a6ba73395ba5b807deef
+ source = https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/bytedance-feishu-beta_4.8.0-24_amd64.deb
+ sha256sums = 0a7acca5f0af6cc23e770aaeb917ac1e9c8f534d14426953b2ae5bf0d61c27ec
pkgname = feishu-bin
diff --git a/PKGBUILD b/PKGBUILD
index ae2d2976e136..412e845cc0bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Maintainer: Allen Zhong <allen@moe.cat>
# Contributor: Feishu Linux Team <contact@feishu.cn>
pkgname=feishu-bin
-pkgver=4.3.0
-_pkgrel=49
+pkgver=4.8.0
+_pkgrel=24
+_pkgtyp=beta
pkgrel=1
pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
@@ -12,11 +13,12 @@ license=('unknown')
groups=('')
depends=('ca-certificates' 'libx11' 'libxcb' 'libxtst' 'nss' 'xdg-utils')
replaces=('bytedance-feishu-stable-bin')
-provides=('bytedance-feishu')
+conflicts=('feishu')
+provides=('bytedance-feishu' 'feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source=("file://bytedance-feishu_${pkgver}-${_pkgrel}_amd64.deb")
-sha256sums=('fbd28428ec3df298a03b7bf61d140b8533b16b4506e7a6ba73395ba5b807deef')
+source=("https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/bytedance-feishu-${_pkgtyp}_${pkgver}-${_pkgrel}_amd64.deb")
+sha256sums=('0a7acca5f0af6cc23e770aaeb917ac1e9c8f534d14426953b2ae5bf0d61c27ec')
package(){
# Extract package data
@@ -24,14 +26,13 @@ package(){
# Modify files
cd "${pkgdir}"
- ln -s bytedance-feishu-stable usr/bin/feishu
+ ln -s bytedance-feishu-${_pkgtyp} usr/bin/feishu
sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/menu/bytedance-feishu.menu"
sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/usr/share/appdata/bytedance-feishu.appdata.xml"
mv "${pkgdir}"/usr/share/menu/{bytedance-,}feishu.menu
mv "${pkgdir}"/usr/share/applications/{bytedance-,}feishu.desktop
mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
- mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu-stable,feishu}.1.gz
- rm "${pkgdir}"/usr/share/man/man1/bytedance-feishu.1.gz
- mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-stable,feishu}
+ mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu,feishu}.1.gz
+ mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-${_pkgtyp},feishu}
}