summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2021-06-11 16:50:16 +0800
committerAllen Zhong2021-09-07 11:46:11 +0800
commit57adf990a064441ea2f17ee46494937226da0678 (patch)
tree9c3a83281136fd112742ace0cc63e5cab1c0e9e4
parentb3489aa73474162fa3d2fb1363fa159f97c1b7ea (diff)
downloadaur-57adf990a064441ea2f17ee46494937226da0678.tar.gz
adjust file contents
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD24
-rw-r--r--feishu-bin.install (renamed from bytedance-feishu-stable-bin.install)1
4 files changed, 31 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37d3eb8cf820..892d47629216 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,23 @@
-pkgbase = bytedance-feishu-stable-bin
- pkgdesc = 飞书Linux版本. 飞书整合即时消息、日历、音视频会议、云文档、工作台等功能于一体,成就团队和个人,更高效、更愉悦。
+pkgbase = feishu-bin
+ pkgdesc = Linux client of Feishu (Lark) from Bytedance.
pkgver = 4.3.0
pkgrel = 1
url = https://www.feishu.cn/
- install = bytedance-feishu-stable-bin.install
+ install = feishu-bin.install
arch = x86_64
groups =
license = unknown
depends = ca-certificates
depends = libx11
+ depends = libxcb
depends = libxtst
+ depends = nss
+ depends = xdg-utils
+ provides = bytedance-feishu
+ replaces = bytedance-feishu-stable-bin
options = !strip
options = !emptydirs
source = file://bytedance-feishu_4.3.0-49_amd64.deb
sha256sums = fbd28428ec3df298a03b7bf61d140b8533b16b4506e7a6ba73395ba5b807deef
-pkgname = bytedance-feishu-stable-bin
+pkgname = feishu-bin
diff --git a/.gitignore b/.gitignore
index abea4f7f8dbf..6960b3a3c146 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
+tmp/
+
*.deb
+*.rpm
*.log
*.xz
*.zst
diff --git a/PKGBUILD b/PKGBUILD
index fc3e2d317991..ae2d2976e136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Generated by debtap
# Maintainer: Allen Zhong <allen@moe.cat>
-pkgname=bytedance-feishu-stable-bin
+# Contributor: Feishu Linux Team <contact@feishu.cn>
+pkgname=feishu-bin
pkgver=4.3.0
_pkgrel=49
pkgrel=1
-pkgdesc="飞书Linux版本. 飞书整合即时消息、日历、音视频会议、云文档、工作台等功能于一体,成就团队和个人,更高效、更愉悦。"
+pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
url="https://www.feishu.cn/"
license=('unknown')
groups=('')
-depends=('ca-certificates' 'libx11' 'libxtst')
-#optdepends=('android-emulator'
-# 'libu2f-udev')
+depends=('ca-certificates' 'libx11' 'libxcb' 'libxtst' 'nss' 'xdg-utils')
+replaces=('bytedance-feishu-stable-bin')
+provides=('bytedance-feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("file://bytedance-feishu_${pkgver}-${_pkgrel}_amd64.deb")
@@ -20,4 +21,17 @@ sha256sums=('fbd28428ec3df298a03b7bf61d140b8533b16b4506e7a6ba73395ba5b807deef')
package(){
# Extract package data
tar xpvf "${srcdir}/data.tar.xz" --xattrs-include='*' --numeric-owner -C "${pkgdir}"
+
+ # Modify files
+ cd "${pkgdir}"
+ ln -s bytedance-feishu-stable usr/bin/feishu
+ sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/menu/bytedance-feishu.menu"
+ sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/usr/share/appdata/bytedance-feishu.appdata.xml"
+ mv "${pkgdir}"/usr/share/menu/{bytedance-,}feishu.menu
+ mv "${pkgdir}"/usr/share/applications/{bytedance-,}feishu.desktop
+ mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
+ mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu-stable,feishu}.1.gz
+ rm "${pkgdir}"/usr/share/man/man1/bytedance-feishu.1.gz
+ mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-stable,feishu}
}
diff --git a/bytedance-feishu-stable-bin.install b/feishu-bin.install
index f5bfbcc0ab0f..2780a0314787 100644
--- a/bytedance-feishu-stable-bin.install
+++ b/feishu-bin.install
@@ -85,7 +85,6 @@ pre_remove() {
# Update cache of .desktop file MIME types. Non-fatal since it's just a cache.
update-desktop-database > /dev/null 2>&1 || true
-
}
post_remove() {