summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAllen Zhong2021-11-05 11:33:40 +0800
committerAllen Zhong2021-11-05 11:57:55 +0800
commita821b238f1358413917cc9a45a04cff8000a38bc (patch)
tree02ffeb11138dcd6a2970d293031e5606c1b4845c
parent95130a9bab9a76817c098257f999cf8213010425 (diff)
downloadaur-a821b238f1358413917cc9a45a04cff8000a38bc.tar.gz
bump v4.11.6_2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 037da173009b..ff1c869cbc3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = feishu-bin
pkgdesc = Linux client of Feishu (Lark) from Bytedance.
- pkgver = 4.8.0
- pkgrel = 3
+ pkgver = 4.11.6
+ pkgrel = 1
url = https://www.feishu.cn/
install = feishu-bin.install
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = feishu-bin
replaces = bytedance-feishu-stable-bin
options = !strip
options = !emptydirs
- source = https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/bytedance-feishu-beta_4.8.0-24_amd64.deb
- sha256sums = 0a7acca5f0af6cc23e770aaeb917ac1e9c8f534d14426953b2ae5bf0d61c27ec
+ source = https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/v5x9pa/bytedance-feishu-beta_4.11.6-2_amd64.deb
+ sha256sums = 9a844502ee721defb1bfe37764c7a3c0fe1dc64c99185ae9b6368826e2fefb5a
pkgname = feishu-bin
diff --git a/PKGBUILD b/PKGBUILD
index e851102c9881..da9d07c36a2f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,11 @@
# Maintainer: Allen Zhong <allen@moe.cat>
# Contributor: Feishu Linux Team <contact@feishu.cn>
pkgname=feishu-bin
-pkgver=4.8.0
-_pkgrel=24
+pkgver=4.11.6
+_pkgrel=2
_pkgtyp=beta
-pkgrel=3
+_pkghash=v5x9pa
+pkgrel=1
pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
url="https://www.feishu.cn/"
@@ -17,8 +18,8 @@ conflicts=('feishu')
provides=('bytedance-feishu' 'feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
-source=("https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/b4f6bd/bytedance-feishu-${_pkgtyp}_${pkgver}-${_pkgrel}_amd64.deb")
-sha256sums=('0a7acca5f0af6cc23e770aaeb917ac1e9c8f534d14426953b2ae5bf0d61c27ec')
+source=("https://sf3-cn.feishucdn.com/obj/suite-public-file-cn/${_pkghash}/bytedance-feishu-${_pkgtyp}_${pkgver}-${_pkgrel}_amd64.deb")
+sha256sums=('9a844502ee721defb1bfe37764c7a3c0fe1dc64c99185ae9b6368826e2fefb5a')
package(){
# Extract package data
@@ -35,4 +36,7 @@ package(){
mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu,feishu}.1.gz
mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-${_pkgtyp},feishu}
+
+ # Fix directory permissions
+ find "${pkgdir}" -type d | xargs chmod 755
}