summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2019-11-20 14:43:15 -0600
committerIvy Foster2019-11-20 14:43:15 -0600
commit529e057893b3d8076d45094b3a254a60ceebd546 (patch)
treed1ba1d1f83ca594aecd66c1d91997e8cb51656d1
parent9ec33ea7d8562a374b38bab4cbb13bcc61bdae9b (diff)
downloadaur-529e057893b3d8076d45094b3a254a60ceebd546.tar.gz
Update to 2.50.r2-g295b6aa-1
- Properly list makedepends for the split package - Add SDL interface - Remove now-unnecessary eccentric Makefile workarounds - List self as contributor, rather than maintainer, since orphaning
-rw-r--r--.SRCINFO54
-rw-r--r--PKGBUILD86
2 files changed, 111 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6fb477a024a4..166078c3702f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,58 @@
pkgbase = frotz-git
pkgdesc = Z-machine interpreter for interactive fiction games
- pkgver = 2.44.r196.gf3ceac9
+ pkgver = 2.50.r2.g295b6aa
pkgrel = 1
- url = http://frotz.sourceforge.net/
- arch = i686
+ url = https://gitlab.com/DavidGriffith/frotz
arch = x86_64
license = GPL
- source = git+https://github.com/DavidGriffith/frotz
+ makedepends = git
+ makedepends = libao
+ makedepends = libmodplug
+ makedepends = libsamplerate
+ makedepends = libsndfile
+ makedepends = libvorbis
+ makedepends = ncurses
+ makedepends = freetype2
+ makedepends = libjpeg-turbo
+ makedepends = libpng
+ makedepends = sdl2
+ makedepends = sdl2_mixer
+ makedepends = zlib
+ source = git+https://gitlab.com/DavidGriffith/frotz.git
md5sums = SKIP
+pkgname = frotz-dumb-git
+ pkgdesc = Z-machine interpreter for interactive fiction games, for dumb terminals or scripting
+ provides = dfrotz
+ provides = frotz-dumb
+ conflicts = frotz-dumb
+
pkgname = frotz-ncurses-git
+ pkgdesc = ncurses-based Z-machine interpreter for interactive fiction games
+ depends = libao
+ depends = libmodplug
+ depends = libsamplerate
+ depends = libsndfile
+ depends = libvorbis
depends = ncurses
provides = frotz
- conflicts = frotz
+ provides = frotz-ncurses
+ conflicts = frotz-ncurses
-pkgname = frotz-dumb-git
- provides = frotz-dumb
- conflicts = frotz-dumb
+pkgname = frotz-sdl-git
+ pkgdesc = Graphical Z-machine interpreter for interactive fiction games
+ depends = libao
+ depends = libmodplug
+ depends = libsamplerate
+ depends = libsndfile
+ depends = libvorbis
+ depends = freetype2
+ depends = libjpeg-turbo
+ depends = libpng
+ depends = sdl2
+ depends = sdl2_mixer
+ depends = zlib
+ provides = sfrotz
+ provides = frotz-sdl
+ conflicts = frotz-sdl
diff --git a/PKGBUILD b/PKGBUILD
index cb5c35c91da7..539fef9c3a06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,34 @@
-# Maintainer: Ivy Foster <code@escondida.tk>
+# Maintainer: Ivy Foster <code@iff.ink>
pkgbase=frotz-git
-pkgname=(frotz-ncurses-git frotz-dumb-git)
-pkgver=2.44.r196.gf3ceac9
+pkgname=(frotz-dumb-git frotz-ncurses-git frotz-sdl-git)
+pkgver=2.50.r2.g295b6aa
pkgrel=1
pkgdesc='Z-machine interpreter for interactive fiction games'
-arch=(i686 x86_64)
-url='http://frotz.sourceforge.net/'
+makedepends=(
+ git
+
+ libao
+ libmodplug
+ libsamplerate
+ libsndfile
+ libvorbis
+
+ ncurses
+
+ freetype2
+ libjpeg-turbo
+ libpng
+ sdl2
+ sdl2_mixer
+ zlib
+)
+
+arch=(x86_64)
+url='https://gitlab.com/DavidGriffith/frotz'
license=(GPL)
-source=('git+https://github.com/DavidGriffith/frotz')
+source=('git+https://gitlab.com/DavidGriffith/frotz.git')
md5sums=(SKIP)
pkgver() {
@@ -17,32 +36,57 @@ pkgver() {
git describe | sed 's@-\(.*\)-@.r\1.@'
}
-prepare() {
+build() {
cd frotz
- sed '/^PREFIX/ s:/usr/local:/usr:
- /^MAN_PREFIX/ s:$:/share:
- ' -i Makefile
+ make PREFIX=/usr dumb ncurses sdl
}
-build() {
+package_frotz-dumb-git() {
+ pkgdesc='Z-machine interpreter for interactive fiction games, for dumb terminals or scripting'
+ provides=(dfrotz frotz-dumb)
+ conflicts=(frotz-dumb)
+
cd frotz
- make OPTS="$CFLAGS $LDFLAGS"
- make OPTS="$CFLAGS $LDFLAGS" dumb
+ make DESTDIR="$pkgdir" PREFIX=/usr install_dumb
}
package_frotz-ncurses-git() {
- conflicts=(frotz)
- provides=(frotz)
- depends=('ncurses')
+ pkgdesc='ncurses-based Z-machine interpreter for interactive fiction games'
+ provides=(frotz frotz-ncurses)
+ conflicts=(frotz-ncurses)
+ depends=(
+ libao
+ libmodplug
+ libsamplerate
+ libsndfile
+ libvorbis
+
+ ncurses
+ )
cd frotz
- make DESTDIR="$pkgdir" install
+ make DESTDIR="$pkgdir" PREFIX=/usr install_frotz
}
-package_frotz-dumb-git() {
- conflicts=(frotz-dumb)
- provides=(frotz-dumb)
+package_frotz-sdl-git() {
+ pkgdesc='Graphical Z-machine interpreter for interactive fiction games'
+ provides=(sfrotz frotz-sdl)
+ conflicts=(frotz-sdl)
+ depends=(
+ libao
+ libmodplug
+ libsamplerate
+ libsndfile
+ libvorbis
+
+ freetype2
+ libjpeg-turbo
+ libpng
+ sdl2
+ sdl2_mixer
+ zlib
+ )
cd frotz
- make DESTDIR="$pkgdir" install_dumb
+ make DESTDIR="$pkgdir" PREFIX=/usr install_sdl
}