summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2021-05-22 11:26:33 +0200
committerFrederic Bezies2021-05-22 11:26:33 +0200
commit556ffa3d5ac7327ead059063cdca2159968c8c40 (patch)
treedf4b76da87ebbe93ce0234623d7801142cb170fe
parent096194e8a03630e4ee61e01f21fab71deb447357 (diff)
downloadaur-556ffa3d5ac7327ead059063cdca2159968c8c40.tar.gz
May 22nd, 2021 update
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD61
2 files changed, 14 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d812e43302c..a27849497ca9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = frotz-git
pkgdesc = Z-machine interpreter for interactive fiction games
- pkgver = 2.52.r89.g898860f
+ pkgver = 2.53.r58.g3e4044b
pkgrel = 1
url = https://gitlab.com/DavidGriffith/frotz
arch = x86_64
@@ -23,6 +23,7 @@ pkgbase = frotz-git
pkgname = frotz-dumb-git
pkgdesc = Z-machine interpreter for interactive fiction games, for dumb terminals or scripting
+ depends = glibc
provides = dfrotz
provides = frotz-dumb
conflicts = frotz-dumb
@@ -33,7 +34,6 @@ pkgname = frotz-ncurses-git
depends = libmodplug
depends = libsamplerate
depends = libsndfile
- depends = libvorbis
depends = ncurses
provides = frotz
provides = frotz-ncurses
@@ -41,17 +41,9 @@ pkgname = frotz-ncurses-git
pkgname = frotz-sdl-git
pkgdesc = Graphical Z-machine interpreter for interactive fiction games
- depends = libao
- depends = libmodplug
- depends = libsamplerate
- depends = libsndfile
- depends = libvorbis
depends = freetype2
depends = libjpeg-turbo
- depends = libpng
- depends = sdl2
depends = sdl2_mixer
- depends = zlib
provides = sfrotz
provides = frotz-sdl
conflicts = frotz-sdl
diff --git a/PKGBUILD b/PKGBUILD
index 6c92e14d0fc4..54dfe11bb07f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,28 +2,11 @@
pkgbase=frotz-git
pkgname=(frotz-dumb-git frotz-ncurses-git frotz-sdl-git)
-pkgver=2.52.r89.g898860f
+pkgver=2.53.r58.g3e4044b
pkgrel=1
pkgdesc='Z-machine interpreter for interactive fiction games'
-
-makedepends=(
- git
-
- libao
- libmodplug
- libsamplerate
- libsndfile
- libvorbis
-
- ncurses
-
- freetype2
- libjpeg-turbo
- libpng
- sdl2
- sdl2_mixer
- zlib
-)
+makedepends=('git' 'libao' 'libmodplug' 'libsamplerate' 'libsndfile' 'libvorbis' 'ncurses'
+ 'freetype2' 'libjpeg-turbo' 'libpng' 'sdl2' 'sdl2_mixer' 'zlib')
arch=(x86_64)
url='https://gitlab.com/DavidGriffith/frotz'
@@ -43,8 +26,9 @@ build() {
package_frotz-dumb-git() {
pkgdesc='Z-machine interpreter for interactive fiction games, for dumb terminals or scripting'
- provides=(dfrotz frotz-dumb)
- conflicts=(frotz-dumb)
+ depends=('glibc')
+ provides=('dfrotz' 'frotz-dumb')
+ conflicts=('frotz-dumb')
cd frotz
make DESTDIR="$pkgdir" PREFIX=/usr install_dumb
@@ -52,17 +36,9 @@ package_frotz-dumb-git() {
package_frotz-ncurses-git() {
pkgdesc='ncurses-based Z-machine interpreter for interactive fiction games'
- provides=(frotz frotz-ncurses)
- conflicts=(frotz-ncurses)
- depends=(
- libao
- libmodplug
- libsamplerate
- libsndfile
- libvorbis
-
- ncurses
- )
+ provides=('frotz' 'frotz-ncurses')
+ conflicts=('frotz-ncurses')
+ depends=('libao' 'libmodplug' 'libsamplerate' 'libsndfile' 'ncurses')
cd frotz
make DESTDIR="$pkgdir" PREFIX=/usr install_frotz
@@ -70,22 +46,9 @@ package_frotz-ncurses-git() {
package_frotz-sdl-git() {
pkgdesc='Graphical Z-machine interpreter for interactive fiction games'
- provides=(sfrotz frotz-sdl)
- conflicts=(frotz-sdl)
- depends=(
- libao
- libmodplug
- libsamplerate
- libsndfile
- libvorbis
-
- freetype2
- libjpeg-turbo
- libpng
- sdl2
- sdl2_mixer
- zlib
- )
+ provides=('sfrotz' 'frotz-sdl')
+ conflicts=('frotz-sdl')
+ depends=('freetype2' 'libjpeg-turbo' 'sdl2_mixer')
cd frotz
make DESTDIR="$pkgdir" PREFIX=/usr install_sdl