summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIvy Foster2016-04-22 22:51:38 -0500
committerIvy Foster2016-04-22 22:51:38 -0500
commit60428f56c069d4807b050fed624437f3af48be75 (patch)
tree436fdc01209d3456d0650075c89b10639548ae2b
downloadaur-60428f56c069d4807b050fed624437f3af48be75.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f4e2366bc31f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = frotz-git
+ pkgdesc = Z-machine interpreter for interactive fiction games
+ pkgver = 2.44.r33.ga98137e
+ pkgrel = 1
+ url = http://frotz.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ conflicts = frotz
+ replaces = frotz
+ source = git+https://github.com/DavidGriffith/frotz
+ md5sums = SKIP
+
+pkgname = frotz-ncurses-git
+ depends = ncurses
+
+pkgname = frotz-dumb-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..84d599db7d1d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Ivy Foster <ivy.foster@gmail.com>
+
+pkgbase='frotz-git'
+pkgname=('frotz-ncurses-git' 'frotz-dumb-git')
+pkgver=2.44.r33.ga98137e
+pkgrel=1
+pkgdesc='Z-machine interpreter for interactive fiction games'
+
+conflicts=('frotz')
+replaces=('frotz')
+
+arch=('i686' 'x86_64')
+url='http://frotz.sourceforge.net/'
+license=('GPL')
+source=('git+https://github.com/DavidGriffith/frotz')
+md5sums=('SKIP')
+
+pkgver() {
+ cd frotz
+ git describe | sed 's,-\(.*\)-,.r\1.,'
+}
+
+prepare() {
+ cd frotz
+ sed '/^PREFIX/ s:/usr/local:/usr:
+ /^CONFIG_DIR = $(PREFIX)/ s/^/#/
+ /^CONFIG_DIR/ s:/usr/local::
+ /^CURSES/ s/-lcurses/-lncurses/
+ /^#CURSES_DEF/ s/^#//' \
+ -i Makefile
+}
+
+build() {
+ cd frotz
+ make OPTS="$CFLAGS $LDFLAGS"
+ make OPTS="$CFLAGS $LDFLAGS" dumb
+}
+
+package_frotz-ncurses-git() {
+ depends=('ncurses')
+
+ cd frotz
+ make DESTDIR="$pkgdir" install
+}
+
+package_frotz-dumb-git() {
+ cd frotz
+ make DESTDIR="$pkgdir" install_dumb
+}