summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-07-03 16:00:03 +0200
committerPellegrino Prevete2023-07-03 16:00:03 +0200
commita8097071def497a9f7eb570b52c6c7e46c7edabe (patch)
treefcfd2ae5aec1590295297321d30ccfe66f1cc841
parent303bf8643e6ec0295f4f68968a30096d5862bb88 (diff)
downloadaur-a8097071def497a9f7eb570b52c6c7e46c7edabe.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD112
2 files changed, 85 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25357a7585a1..4e181b6aa252 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,32 +7,31 @@ pkgbase = gtk2-maemo
arch = any
license = LGPL
makedepends = gobject-introspection
- makedepends = git
makedepends = gtk-doc
makedepends = hicolor-icon-theme
depends = atk
- depends = pango
+ depends = cairo
+ depends = desktop-file-utils
+ depends = gtk-update-icon-cache
+ depends = libcups
+ depends = librsvg
depends = libxcursor
depends = libxinerama
depends = libxrandr
depends = libxi
depends = libxcomposite
depends = libxdamage
+ depends = pango
depends = shared-mime-info
- depends = cairo
- depends = libcups
- depends = gtk-update-icon-cache
- depends = librsvg
- depends = desktop-file-utils
optdepends = gnome-themes-standard: Default widget theme
optdepends = adwaita-icon-theme: Default icon theme
optdepends = python: gtk-builder-convert
provides = libgailutil.so
provides = libgdk-x11-2.0.so
provides = libgtk-x11-2.0.so
- provides = gtk2
+ provides = gtk2=2.24.33
conflicts = gtk2
- source = gtk2::git+https://gitlab.gnome.org/tallero/gtk.git#branch=maemo
+ source = https://gitlab.gnome.org/tallero/gtk/-/archive/ba8b5e7650e26e247488a26c71e82152faf319c2/gtk-ba8b5e7650e26e247488a26c71e82152faf319c2.tar.gz
source = gtkrc
source = gtk-query-immodules-2.0.hook
source = xid-collision-debug.patch
diff --git a/PKGBUILD b/PKGBUILD
index 7094ec46874b..9b8f3076f9fe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,48 +4,88 @@
# Contributor: Nikita Ukhrenkov <thekit@disroot.org>
# Contributor: Bart Ribbers <bribbers@disroot.org>
-_pkgname=gtk2
-pkgname=$_pkgname-maemo
+_pkg="gtk"
+_pkgname="${_pkg}2"
+_variant="maemo"
+pkgname="${_pkgname}-${_variant}"
pkgver=2.24.33
pkgrel=1
pkgdesc="GObject-based multi-platform GUI toolkit (legacy)"
arch=(any)
-url="https://www.gtk.org/"
-depends=(atk pango libxcursor libxinerama libxrandr libxi libxcomposite libxdamage
- shared-mime-info cairo libcups gtk-update-icon-cache librsvg desktop-file-utils)
-makedepends=(gobject-introspection git gtk-doc hicolor-icon-theme)
-optdepends=('gnome-themes-standard: Default widget theme'
- 'adwaita-icon-theme: Default icon theme'
- 'python: gtk-builder-convert')
-provides=(libgailutil.so libg{d,t}k-x11-2.0.so $_pkgname)
-conflicts=($_pkgname)
+url="https://www.${_pkg}.org/"
+_ns="tallero"
+_url="https://gitlab.gnome.org/${_ns}/${_pkg}"
+depends=(
+ atk
+ cairo
+ desktop-file-utils
+ "${_pkg}-update-icon-cache"
+ libcups
+ librsvg
+ libxcursor
+ libxinerama
+ libxrandr
+ libxi
+ libxcomposite
+ libxdamage
+ pango
+ shared-mime-info
+)
+makedepends=(
+ # git
+ gobject-introspection
+ "${_pkg}-doc"
+ hicolor-icon-theme
+)
+optdepends=(
+ 'gnome-themes-standard: Default widget theme'
+ 'adwaita-icon-theme: Default icon theme'
+ "python: ${_pkg}-builder-convert"
+)
+provides=(
+ libgailutil.so
+ libg{d,t}k-x11-2.0.so
+ "${_pkgname}=${pkgver}"
+)
+conflicts=(
+ "${_pkgname}"
+)
license=(LGPL)
-install=$_pkgname.install
-source=("$_pkgname::git+https://gitlab.gnome.org/tallero/gtk.git#branch=maemo"
- gtkrc
- gtk-query-immodules-2.0.hook
- xid-collision-debug.patch)
-sha512sums=('SKIP'
- 'b124433dd4b20d1d62f073df87e253ca23b3b51625cce55f29a220a4369eda5108c0de07fdc686f570232322c3ff04f7758383f2be5aeace40f843907aa3696d'
- '5e99c5558bf48dc251134869c6310bd9e4bce3775a93547f62028fe32b415c18079da89fe46c85d80b54c4810732acbd6b88ec9946962d02fafc46ed7f672cf2'
- 'c473ac89fab47cc79e912695aa7408c22c4bcd998e00f9b00d46374d4a961d41ffaa1f885bf2f9d9b68a401e16f64c617f0dfb058a98469dbe16beb37229b9bc')
+install="${_pkgname}.install"
+_commit="ba8b5e7650e26e247488a26c71e82152faf319c2"
+source=(
+ # "${_pkgname}::git+${_url}.git#branch=${_variant}"
+ "${_url}/-/archive/${_commit}/${_pkg}-${_commit}.tar.gz"
+ "${_pkg}rc"
+ "${_pkg}-query-immodules-2.0.hook"
+ xid-collision-debug.patch
+)
+sha512sums=(
+ 'SKIP'
+ 'b124433dd4b20d1d62f073df87e253ca23b3b51625cce55f29a220a4369eda5108c0de07fdc686f570232322c3ff04f7758383f2be5aeace40f843907aa3696d'
+ '5e99c5558bf48dc251134869c6310bd9e4bce3775a93547f62028fe32b415c18079da89fe46c85d80b54c4810732acbd6b88ec9946962d02fafc46ed7f672cf2'
+ 'c473ac89fab47cc79e912695aa7408c22c4bcd998e00f9b00d46374d4a961d41ffaa1f885bf2f9d9b68a401e16f64c617f0dfb058a98469dbe16beb37229b9bc'
+)
prepare() {
- cd $_pkgname
+ cd "${_pkg}-${_commit}"
git apply -3 ../xid-collision-debug.patch
}
build() {
- cd $_pkgname
+ local _configure_opts=(
+ --build=$CBUILD
+ --host=$CHOST
+ --prefix=/usr
+ --sysconfdir=/etc
+ --localstatedir=/var
+ --with-xinput=yes
+ )
+
+ cd "${_pkg}-${_commit}"
./autogen.sh
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --with-xinput=yes \
+ ./configure "${_configure_opts[@]}"
# https://bugzilla.gnome.org/show_bug.cgi?id=655517
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
@@ -54,14 +94,16 @@ build() {
}
package() {
- cd $_pkgname
- make DESTDIR="$pkgdir" install
+ cd "${_pkg}-${_commit}"
+ make DESTDIR="${pkgdir}" install
- install -Dt "$pkgdir/usr/share/gtk-2.0" -m644 ../gtkrc
- install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../gtk-query-immodules-2.0.hook
+ install -Dt "${pkgdir}/usr/share/${_pkg}-2.0" \
+ -m644 "../${_pkg}rc"
+ install -Dt "${pkgdir}/usr/share/libalpm/hooks" \
+ -m644 "../${_pkg}-query-immodules-2.0.hook"
- rm "$pkgdir/usr/bin/gtk-update-icon-cache"
- libtool --finish $pkgdir/usr/lib
+ rm "${pkgdir}/usr/bin/${_pkg}-update-icon-cache"
+ libtool --finish "${pkgdir}/usr/lib"
}
# vim:set et sw=2: