summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2019-09-09 10:02:11 -0400
committerAndrew Sun2019-09-09 10:02:11 -0400
commit354da638178009849a76bc508eed918c6461e909 (patch)
treea937b9fbb4238ad5aa32a61441ced47d7524ffb5
parentda85e8c38b67aed63dcbe3612657206ba4d9c761 (diff)
downloadaur-354da638178009849a76bc508eed918c6461e909.tar.gz
mingw-w64-atk: update to 2.34.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 19 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f8f3047cb01..d8d158b54031 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = mingw-w64-atk
- pkgdesc = A library providing a set of interfaces for accessibility (mingw-w64)
- pkgver = 2.32.0
- pkgrel = 2
+ pkgdesc = Interface definitions of accessibility infrastructure (mingw-w64)
+ pkgver = 2.34.0
+ pkgrel = 1
url = https://gitlab.gnome.org/GNOME/atk
arch = any
license = LGPL
makedepends = mingw-w64-gcc
makedepends = mingw-w64-meson
makedepends = python
+ makedepends = git
depends = mingw-w64-crt
depends = mingw-w64-glib2
options = !strip
options = !buildflags
options = staticlibs
- source = http://ftp.gnome.org/pub/gnome/sources/atk/2.32/atk-2.32.0.tar.xz
- sha256sums = cb41feda7fe4ef0daa024471438ea0219592baf7c291347e5a858bb64e4091cc
+ source = git+https://gitlab.gnome.org/GNOME/atk.git#commit=ae00132c6ef58d779e9389a10badb2f43ee35606
+ sha256sums = SKIP
pkgname = mingw-w64-atk
diff --git a/PKGBUILD b/PKGBUILD
index a889a6c562b4..516b52373534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
-# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
# Contributor: <nontlikeuname at tuta dot io>
pkgname=mingw-w64-atk
-pkgver=2.32.0
-pkgrel=2
-pkgdesc="A library providing a set of interfaces for accessibility (mingw-w64)"
+pkgver=2.34.0
+pkgrel=1
+pkgdesc="Interface definitions of accessibility infrastructure (mingw-w64)"
arch=('any')
url="https://gitlab.gnome.org/GNOME/atk"
license=('LGPL')
-makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'python')
+makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'python' 'git')
depends=('mingw-w64-crt' 'mingw-w64-glib2')
options=('!strip' '!buildflags' 'staticlibs')
-source=("http://ftp.gnome.org/pub/gnome/sources/atk/${pkgver%.*}/atk-${pkgver}.tar.xz")
-sha256sums=('cb41feda7fe4ef0daa024471438ea0219592baf7c291347e5a858bb64e4091cc')
+_commit=ae00132c6ef58d779e9389a10badb2f43ee35606 # tags/ATK_2_34_00^0
+source=("git+https://gitlab.gnome.org/GNOME/atk.git#commit=$_commit")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/atk-${pkgver}"
+ cd "${srcdir}/atk"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-meson \
@@ -25,6 +26,7 @@ build() {
--default-library=both \
-Ddocs=false \
-Dintrospection=false \
+ -Dstrip=false \
..
ninja
popd
@@ -33,13 +35,11 @@ build() {
package() {
for _arch in ${_architectures}; do
- DESTDIR="${pkgdir}" meson install -C ${srcdir}/atk-${pkgver}/build-${_arch}
+ DESTDIR="${pkgdir}" meson install -C ${srcdir}/atk/build-${_arch}
rm -r ${pkgdir}/usr/${_arch}/share
- #FIXME: Ranlib (isn't meson supposed to do this?)
- ${_arch}-ranlib ${pkgdir}/usr/${_arch}/lib/*.a
-
- ${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
}