summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2018-06-12 14:09:06 -0400
committerAndrew Sun2018-06-12 14:09:06 -0400
commitd337e2536a0d27ff044218d33082b9a67e3cc592 (patch)
tree7032075e0a2b8bc6666b493976819540c5814fad
parente53a92147df2999e3687216b84ac114e008e39f0 (diff)
downloadaur-d337e2536a0d27ff044218d33082b9a67e3cc592.tar.gz
mingw-w64-atk: update to 2.28.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a472c41a43a0..be8e265e6548 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,10 @@
-# Generated by mksrcinfo v8
-# Tue Dec 22 12:15:24 UTC 2015
pkgbase = mingw-w64-atk
pkgdesc = A library providing a set of interfaces for accessibility (mingw-w64)
- pkgver = 2.18.0
+ pkgver = 2.28.1
pkgrel = 1
url = https://developer.gnome.org/atk/
arch = any
- license = LGPL
+ license = LGPL2
makedepends = mingw-w64-gcc
makedepends = mingw-w64-configure
depends = mingw-w64-crt
@@ -14,8 +12,8 @@ pkgbase = mingw-w64-atk
options = !strip
options = !buildflags
options = staticlibs
- source = http://ftp.gnome.org/pub/gnome/sources/atk/2.18/atk-2.18.0.tar.xz
- md5sums = fd3678f35004b4c92e3da39356996054
+ source = http://ftp.gnome.org/pub/gnome/sources/atk/2.28/atk-2.28.1.tar.xz
+ md5sums = dfb5e7474220afa3f4ca7e45af9f3a11
pkgname = mingw-w64-atk
diff --git a/PKGBUILD b/PKGBUILD
index 8ccda3b941c2..b4afed7e481b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: <nontlikeuname at tuta dot io>
+# Maintainer: Andrew Sun <adsun701@gmail.com>
+# Contributor: <nontlikeuname at tuta dot io>
pkgname=mingw-w64-atk
-pkgver=2.18.0
+pkgver=2.28.1
pkgrel=1
pkgdesc="A library providing a set of interfaces for accessibility (mingw-w64)"
arch=('any')
url="https://developer.gnome.org/atk/"
-license=('LGPL')
+license=('LGPL2')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
depends=('mingw-w64-crt' 'mingw-w64-glib2')
options=('!strip' '!buildflags' 'staticlibs')
-source=("http://ftp.gnome.org/pub/gnome/sources/atk/${pkgver:0:4}/atk-${pkgver}.tar.xz")
-md5sums=('fd3678f35004b4c92e3da39356996054')
+source=("http://ftp.gnome.org/pub/gnome/sources/atk/${pkgver%.*}/atk-${pkgver}.tar.xz")
+md5sums=('dfb5e7474220afa3f4ca7e45af9f3a11')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -19,7 +20,10 @@ build() {
cd "${srcdir}/atk-${pkgver}/"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure --disable-glibtest
+ ${_arch}-configure \
+ --disable-introspection \
+ --without-libintl-prefix \
+ --without-libiconv-prefix
make
popd
done
@@ -34,4 +38,3 @@ package() {
rm -r ${pkgdir}/usr/${_arch}/share
done
}
-