summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Murino2018-05-28 18:35:53 +0200
committerNicola Murino2018-05-28 18:35:53 +0200
commit7d2f990c2ecc9ff70a1cb070122d1abf42f250e8 (patch)
tree1ce8f2fa43930d37d1b04366feb1b70c0dd561ab
parentbc6a26c135b446b113b371b0c2334e0a6e0f5c5d (diff)
downloadaur-7d2f990c2ecc9ff70a1cb070122d1abf42f250e8.tar.gz
Update to 1.15.12-1
-rw-r--r--.SRCINFO16
-rw-r--r--0027-win32-print-fix-unbounded-surface-assertion.patch21
-rw-r--r--0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch138
-rw-r--r--PKGBUILD32
4 files changed, 47 insertions, 160 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 313a54013b91..8fe4e9aa69f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 5 13:55:29 UTC 2018
+# Mon May 28 16:35:43 UTC 2018
pkgbase = mingw-w64-cairo-bootstrap
pkgdesc = Cairo vector graphics library (mingw-w64 bootstrap)
- pkgver = 1.14.12
+ pkgver = 1.15.12
pkgrel = 1
url = http://cairographics.org/
arch = any
@@ -17,14 +17,14 @@ pkgbase = mingw-w64-cairo-bootstrap
options = !strip
options = !buildflags
options = staticlibs
- source = http://cairographics.org/releases/cairo-1.14.12.tar.xz
+ source = https://cairographics.org/snapshots/cairo-1.15.12.tar.xz
source = 0009-standalone-headers.mingw.patch
source = 0026-create-argb-fonts.all.patch
- source = 0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch
- sha1sums = 490025a0ba0622a853010f49fb6343f29fb70b9b
- sha1sums = 58c548d2791ba20dd7f6e328ff596f746df3aa10
- sha1sums = 9c0e533614782a41af2c3806a43ab7fe9d6a5431
- sha1sums = c0c9546f120133b8e5b116650ba233a15a1e20c4
+ source = 0027-win32-print-fix-unbounded-surface-assertion.patch
+ sha256sums = 7623081b94548a47ee6839a7312af34e9322997806948b6eec421a8c6d0594c9
+ sha256sums = 234de8c5d4c28b03c19e638a353e8defb2de0367a634c002b0ea7d2877bd0756
+ sha256sums = 6db6c44fbdb4926d09afa978fe80430186c4b7b7d255059602b1f94c6a079975
+ sha256sums = 7e244c20eec8c7b287dbee1d34de178d9b0c419dc4c2b11c90eaf626c92bf781
pkgname = mingw-w64-cairo-bootstrap
diff --git a/0027-win32-print-fix-unbounded-surface-assertion.patch b/0027-win32-print-fix-unbounded-surface-assertion.patch
new file mode 100644
index 000000000000..524402b22df9
--- /dev/null
+++ b/0027-win32-print-fix-unbounded-surface-assertion.patch
@@ -0,0 +1,21 @@
+diff -ru cairo-1.15.6/src/win32/cairo-win32-printing-surface.c cairo-1.15.6b/src/win32/cairo-win32-printing-surface.c
+--- cairo-1.15.6/src/win32/cairo-win32-printing-surface.c 2017-06-09 08:46:49.000000000 +0200
++++ cairo-1.15.6b/src/win32/cairo-win32-printing-surface.c 2017-07-26 21:41:09.380698500 +0200
+@@ -335,7 +335,7 @@
+ static cairo_bool_t
+ surface_pattern_supported (const cairo_surface_pattern_t *pattern)
+ {
+- if (_cairo_surface_is_recording (pattern->surface))
++ if (pattern->surface->type == CAIRO_SURFACE_TYPE_RECORDING)
+ return TRUE;
+
+ if (pattern->surface->backend->acquire_source_image == NULL)
+@@ -1119,7 +1119,7 @@
+ case CAIRO_PATTERN_TYPE_SURFACE: {
+ cairo_surface_pattern_t *surface_pattern = (cairo_surface_pattern_t *) pattern;
+
+- if ( _cairo_surface_is_recording (surface_pattern->surface))
++ if (surface_pattern->surface->type == CAIRO_SURFACE_TYPE_RECORDING)
+ status = _cairo_win32_printing_surface_paint_recording_pattern (surface, surface_pattern);
+ else
+ status = _cairo_win32_printing_surface_paint_image_pattern (surface, pattern, extents);
diff --git a/0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch b/0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch
deleted file mode 100644
index 70d90ff98bdd..000000000000
--- a/0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch
+++ /dev/null
@@ -1,138 +0,0 @@
-From 16898ba11b4d6e9e2e64bb2d02d0fb5adbe266e2 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=D0=A0=D1=83=D1=81=D0=BB=D0=B0=D0=BD=20=D0=98=D0=B6=D0=B1?=
- =?UTF-8?q?=D1=83=D0=BB=D0=B0=D1=82=D0=BE=D0=B2?= <lrn1986@gmail.com>
-Date: Thu, 26 Mar 2015 19:33:43 +0000
-Subject: win32: Add cairo API to set up a Win32 surface for an HDC with an
- alpha channel.
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Руслан Ижбулатов <lrn1986@gmail.com>
-Reviewed-by: Bryce Harrington <bryce@osg.samsung.com>
-
-diff --git a/src/cairo-win32.h b/src/cairo-win32.h
-index 3d2e1c6..db4cac6 100644
---- a/src/cairo-win32.h
-+++ b/src/cairo-win32.h
-@@ -49,6 +49,10 @@ cairo_public cairo_surface_t *
- cairo_win32_surface_create (HDC hdc);
-
- cairo_public cairo_surface_t *
-+cairo_win32_surface_create_with_format (HDC hdc,
-+ cairo_format_t format);
-+
-+cairo_public cairo_surface_t *
- cairo_win32_printing_surface_create (HDC hdc);
-
- cairo_public cairo_surface_t *
-diff --git a/src/win32/cairo-win32-display-surface.c b/src/win32/cairo-win32-display-surface.c
-index 965f2c4..1571480 100644
---- a/src/win32/cairo-win32-display-surface.c
-+++ b/src/win32/cairo-win32-display-surface.c
-@@ -917,31 +917,41 @@ static const cairo_surface_backend_t cairo_win32_display_surface_backend = {
- */
-
- /**
-- * cairo_win32_surface_create:
-+ * cairo_win32_surface_create_with_format:
- * @hdc: the DC to create a surface for
-+ * @format: format of pixels in the surface to create
- *
- * Creates a cairo surface that targets the given DC. The DC will be
- * queried for its initial clip extents, and this will be used as the
-- * size of the cairo surface. The resulting surface will always be of
-- * format %CAIRO_FORMAT_RGB24; should you need another surface format,
-- * you will need to create one through
-- * cairo_win32_surface_create_with_dib().
-+ * size of the cairo surface.
- *
-- * Return value: the newly created surface
-+ * Supported formats are:
-+ * %CAIRO_FORMAT_ARGB32
-+ * %CAIRO_FORMAT_RGB24
- *
-- * Since: 1.0
-+ * Note: @format only tells cairo how to draw on the surface, not what
-+ * the format of the surface is. Namely, cairo does not (and cannot)
-+ * check that @hdc actually supports alpha-transparency.
-+ *
-+ * Return value: the newly created surface, NULL on failure
-+ *
-+ * Since: 1.14.3
- **/
- cairo_surface_t *
--cairo_win32_surface_create (HDC hdc)
-+cairo_win32_surface_create_with_format (HDC hdc, cairo_format_t format)
- {
- cairo_win32_display_surface_t *surface;
-
-- cairo_format_t format;
- cairo_status_t status;
- cairo_device_t *device;
-
-- /* Assume that everything coming in as a HDC is RGB24 */
-- format = CAIRO_FORMAT_RGB24;
-+ switch (format) {
-+ default:
-+ return _cairo_surface_create_in_error (_cairo_error (CAIRO_STATUS_INVALID_FORMAT));
-+ case CAIRO_FORMAT_ARGB32:
-+ case CAIRO_FORMAT_RGB24:
-+ break;
-+ }
-
- surface = malloc (sizeof (*surface));
- if (surface == NULL)
-@@ -977,6 +987,28 @@ cairo_win32_surface_create (HDC hdc)
- }
-
- /**
-+ * cairo_win32_surface_create:
-+ * @hdc: the DC to create a surface for
-+ *
-+ * Creates a cairo surface that targets the given DC. The DC will be
-+ * queried for its initial clip extents, and this will be used as the
-+ * size of the cairo surface. The resulting surface will always be of
-+ * format %CAIRO_FORMAT_RGB24; should you need another surface format,
-+ * you will need to create one through
-+ * cairo_win32_surface_create_with_format() or
-+ * cairo_win32_surface_create_with_dib().
-+ *
-+ * Return value: the newly created surface, NULL on failure
-+ *
-+ * Since: 1.0
-+ **/
-+cairo_surface_t *
-+cairo_win32_surface_create (HDC hdc)
-+{
-+ return cairo_win32_surface_create_with_format (hdc, CAIRO_FORMAT_RGB24);
-+}
-+
-+/**
- * cairo_win32_surface_create_with_dib:
- * @format: format of pixels in the surface to create
- * @width: width of the surface, in pixels
-@@ -1027,12 +1059,16 @@ cairo_win32_surface_create_with_ddb (HDC hdc,
- HDC screen_dc, ddb_dc;
- HBITMAP saved_dc_bitmap;
-
-- if (format != CAIRO_FORMAT_RGB24)
-+ switch (format) {
-+ default:
-+/* XXX handle these eventually */
-+ case CAIRO_FORMAT_A8:
-+ case CAIRO_FORMAT_A1:
- return _cairo_surface_create_in_error (_cairo_error (CAIRO_STATUS_INVALID_FORMAT));
--/* XXX handle these eventually
-- format != CAIRO_FORMAT_A8 ||
-- format != CAIRO_FORMAT_A1)
--*/
-+ case CAIRO_FORMAT_ARGB32:
-+ case CAIRO_FORMAT_RGB24:
-+ break;
-+ }
-
- if (!hdc) {
- screen_dc = GetDC (NULL);
---
-cgit v0.10.2
diff --git a/PKGBUILD b/PKGBUILD
index 54d12f25a7ea..3204c85ef1be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
-# Maintainer: Chris Kitching <chriskitching@linux.com>
+# Maintainer: drakkan <nicola.murino at gmail dot com>
+# Contributor: Chris Kitching <chriskitching@linux.com>
# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
pkgname=mingw-w64-cairo-bootstrap
-pkgver=1.14.12
+pkgver=1.15.12
pkgrel=1
pkgdesc="Cairo vector graphics library (mingw-w64 bootstrap)"
arch=(any)
@@ -12,22 +13,21 @@ depends=(mingw-w64-pixman mingw-w64-glib2 mingw-w64-fontconfig)
options=(!strip !buildflags staticlibs)
provides=(${pkgname%-bootstrap})
conflicts=(${pkgname%-bootstrap})
-source=("http://cairographics.org/releases/cairo-${pkgver}.tar.xz"
-"0009-standalone-headers.mingw.patch"
-"0026-create-argb-fonts.all.patch"
-"0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch")
-sha1sums=('490025a0ba0622a853010f49fb6343f29fb70b9b'
- '58c548d2791ba20dd7f6e328ff596f746df3aa10'
- '9c0e533614782a41af2c3806a43ab7fe9d6a5431'
- 'c0c9546f120133b8e5b116650ba233a15a1e20c4')
-
+source=("https://cairographics.org/snapshots/cairo-${pkgver}.tar.xz"
+ "0009-standalone-headers.mingw.patch"
+ "0026-create-argb-fonts.all.patch"
+ "0027-win32-print-fix-unbounded-surface-assertion.patch")
+sha256sums=('7623081b94548a47ee6839a7312af34e9322997806948b6eec421a8c6d0594c9'
+ '234de8c5d4c28b03c19e638a353e8defb2de0367a634c002b0ea7d2877bd0756'
+ '6db6c44fbdb4926d09afa978fe80430186c4b7b7d255059602b1f94c6a079975'
+ '7e244c20eec8c7b287dbee1d34de178d9b0c419dc4c2b11c90eaf626c92bf781')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
- cd cairo-$pkgver
- patch -p1 -i ${srcdir}/0009-standalone-headers.mingw.patch
+ cd cairo-$pkgver
+ patch -p1 -i ${srcdir}/0009-standalone-headers.mingw.patch
patch -p1 -i ${srcdir}/0026-create-argb-fonts.all.patch
- patch -p1 -i ${srcdir}/0030-add-cairo-API-to-setup-Win32-surface-for-HDC.patch
+ patch -p1 -i ${srcdir}/0027-win32-print-fix-unbounded-surface-assertion.patch
autoreconf -fi
}
@@ -43,6 +43,8 @@ build() {
--enable-tee \
--disable-xlib \
--disable-xcb \
+ --disable-gtk-doc \
+ --disable-gtk-doc-html \
ac_cv_prog
make
popd
@@ -58,3 +60,5 @@ package() {
rm -r "$pkgdir/usr/${_arch}/share"
done
}
+
+# vim: ts=2 sw=2 et: