summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoboron30422023-06-29 21:37:30 +0200
committerRoboron30422023-06-29 21:37:30 +0200
commit721f5d1655565c125a6e6d539fd256ff726d4f84 (patch)
treedc00d08e0fec583e49556969ae55098254510b27
parent49a17365ea8b2f00cdf44d900816430c71c4b74b (diff)
downloadaur-721f5d1655565c125a6e6d539fd256ff726d4f84.tar.gz
Version 2.3.3
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85461d0a2eb2..ceb995f79a86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mingw-w64-fluidsynth
pkgdesc = A real-time software synthesizer based on the SoundFont 2 specifications (mingw-w64)
- pkgver = 2.3.2
+ pkgver = 2.3.3
pkgrel = 1
url = http://www.fluidsynth.org/
arch = any
@@ -12,10 +12,11 @@ pkgbase = mingw-w64-fluidsynth
depends = mingw-w64-libsndfile
depends = mingw-w64-portaudio
depends = mingw-w64-readline
+ depends = mingw-w64-sdl2
options = staticlibs
options = !buildflags
options = !strip
- source = fluidsynth-2.3.2.tar.gz::https://github.com/FluidSynth/fluidsynth/archive/v2.3.2.tar.gz
- sha256sums = cd610810f30566e28fb98c36501f00446a06fa6bae3dc562c8cd3868fe1c0fc7
+ source = fluidsynth-2.3.3.tar.gz::https://github.com/FluidSynth/fluidsynth/archive/v2.3.3.tar.gz
+ sha256sums = 321f7d3f72206b2522f30a1cb8ad1936fd4533ffc4d29dd335b1953c9fb371e6
pkgname = mingw-w64-fluidsynth
diff --git a/PKGBUILD b/PKGBUILD
index 4f32b51c4fb7..94119e9064c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_realname=fluidsynth
pkgname=mingw-w64-fluidsynth
-pkgver=2.3.2
+pkgver=2.3.3
pkgrel=1
pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications (mingw-w64)"
url="http://www.fluidsynth.org/"
@@ -11,13 +11,14 @@ license=('LGPL')
depends=('mingw-w64-glib2'
'mingw-w64-libsndfile'
'mingw-w64-portaudio'
- 'mingw-w64-readline')
+ 'mingw-w64-readline'
+ 'mingw-w64-sdl2')
makedepends=('mingw-w64-cmake'
'mingw-w64-pkg-config'
'mingw-w64-make')
options=('staticlibs' '!buildflags' '!strip')
source=("${_realname}-${pkgver}.tar.gz::https://github.com/FluidSynth/${_realname}/archive/v${pkgver}.tar.gz")
-sha256sums=('cd610810f30566e28fb98c36501f00446a06fa6bae3dc562c8cd3868fe1c0fc7')
+sha256sums=('321f7d3f72206b2522f30a1cb8ad1936fd4533ffc4d29dd335b1953c9fb371e6')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -26,11 +27,11 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- # If you need every feature, use this
- #${_arch}-cmake -DBUILD_SHARED_LIBS=0 -Denable-portaudio=1 -Denable-dbus=0 ..
-
- # If you only need the bare minimum to play with SF2/SF3 soundfonts with SDL2, uncomment this instead
- ${_arch}-cmake -DBUILD_SHARED_LIBS=0 -Denable-aufile=0 -Denable-dbus=0 -Denable-ipv6=0 -Denable-jack=0 -Denable-ladspa=0 -Denable-midishare=0 -Denable-opensles=0 -Denable-oboe=0 -Denable-oss=0 -Denable-readline=0 -Denable-winmidi=0 -Denable-waveout=0 -Denable-network=0 -Denable-pulseaudio=0 -Denable-dsound=0 -Denable-alsa=0 -Denable-libinstpatch=0 -Denable-portaudio=0 -Denable-wasapi=0 -Denable-openmp=1 -Denable-libsndfile=0 -Denable-sdl2=1 ..
+ # If you need every feature, use this
+ ${_arch}-cmake -DBUILD_SHARED_LIBS=0 -Denable-portaudio=1 -Denable-dbus=0 ..
+
+ # If you only need the bare minimum to play with SF2/SF3 soundfonts with SDL2, uncomment this instead
+ #${_arch}-cmake -DBUILD_SHARED_LIBS=0 -Denable-aufile=0 -Denable-dbus=0 -Denable-ipv6=0 -Denable-jack=0 -Denable-ladspa=0 -Denable-midishare=0 -Denable-opensles=0 -Denable-oboe=0 -Denable-oss=0 -Denable-readline=0 -Denable-winmidi=0 -Denable-waveout=0 -Denable-network=0 -Denable-pulseaudio=0 -Denable-dsound=0 -Denable-alsa=0 -Denable-libinstpatch=0 -Denable-portaudio=0 -Denable-wasapi=0 -Denable-openmp=1 -Denable-libsndfile=0 -Denable-sdl2=1 ..
make
popd
done