summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros Theodotou2020-05-17 03:24:59 +0100
committerAlexandros Theodotou2020-05-17 03:24:59 +0100
commitc7e27407be7019fd083a7fcea6f9bb250d103d1f (patch)
tree7ead7b8bc249f2281e4727126e4f24ceb081a7f1
downloadaur-c7e27407be7019fd083a7fcea6f9bb250d103d1f.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD45
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1712c0c0133c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mingw-w64-fluidsynth
+ pkgdesc = A real-time software synthesizer based on the SoundFont 2 specifications (mingw-w64)
+ pkgver = 2.1.2
+ pkgrel = 2
+ url = http://www.zstd.net/
+ arch = any
+ license = BSD
+ license = GPL2
+ makedepends = mingw-w64-cmake
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-gcc
+ depends = mingw-w64-glib2
+ depends = mingw-w64-libsndfile
+ depends = mingw-w64-portaudio
+ depends = mingw-w64-readline
+ options = staticlibs
+ options = !buildflags
+ options = !strip
+ source = fluidsynth-2.1.2.tar.gz::https://github.com/FluidSynth/fluidsynth/archive/v2.1.2.tar.gz
+ sha256sums = 9206d83b8d2f7e1ec259ee01e943071de67e419aabe142b51312f8edb39c5503
+
+pkgname = mingw-w64-fluidsynth
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d7b46fbb5f6a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e40a869874ed
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+
+_realname=fluidsynth
+pkgname=mingw-w64-fluidsynth
+pkgver=2.1.2
+pkgrel=2
+pkgdesc="A real-time software synthesizer based on the SoundFont 2 specifications (mingw-w64)"
+url="http://www.zstd.net/"
+arch=('any')
+license=('BSD' 'GPL2')
+depends=('mingw-w64-gcc'
+ 'mingw-w64-glib2'
+ 'mingw-w64-libsndfile'
+ 'mingw-w64-portaudio'
+ 'mingw-w64-readline')
+makedepends=('mingw-w64-cmake'
+ 'mingw-w64-pkg-config')
+options=('staticlibs' '!buildflags' '!strip')
+source=("${_realname}-${pkgver}.tar.gz::https://github.com/FluidSynth/${_realname}/archive/v${pkgver}.tar.gz")
+sha256sums=('9206d83b8d2f7e1ec259ee01e943071de67e419aabe142b51312f8edb39c5503')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd fluidsynth-$pkgver
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ ${_arch}-cmake \
+ -DCMAKE_INSTALL_PREFIX=$pkgdir/usr/${_arch} \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DBUILD_STATIC_LIBS=ON \
+ -Denable-portaudio=ON \
+ -Denable-dbus=OFF \
+ ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "$srcdir"/fluidsynth-${pkgver}/build-${_arch}
+ ${_arch}-make install DESTDIR="$pkgdir"
+ done
+}
+