summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2013-05-18 11:42:59 +0800
committerTing-Wei Lan2013-05-18 11:42:59 +0800
commit911d9ad00fcafcf50defcb1be611cbdcca00fd1c (patch)
tree5cd1bdabfa0f6815eb91c78aed016f43e1535a89
downloadaur-911d9ad00fcafcf50defcb1be611cbdcca00fd1c.tar.gz
mingw-w64-gtk2: 2.24.17-3 -> 2.24.18-1
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD61
2 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8ba622bdeac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = mingw-w64-gtk2
+ pkgdesc = GTK+ is a multi-platform toolkit (v2) (mingw-w64)
+ pkgver = 2.24.18
+ pkgrel = 1
+ url = http://www.gtk.org
+ arch = any
+ license = LGPL
+ makedepends = mingw-w64-gcc
+ makedepends = mingw-w64-pkg-config
+ depends = mingw-w64-crt
+ depends = mingw-w64-atk
+ depends = mingw-w64-pango
+ depends = mingw-w64-glib2
+ depends = mingw-w64-cairo
+ depends = mingw-w64-gdk-pixbuf2
+ options = !libtool
+ options = !strip
+ options = !buildflags
+ source = http://ftp.gnome.org/pub/gnome/sources/gtk+/2.24/gtk+-2.24.18.tar.xz
+ source = http://pkgs.fedoraproject.org/cgit/mingw-gtk2.git/plain/gtk-dont-define-initguid.patch?id=3224e445dad240da5f5ebfe371e8c9f627459089
+ md5sums = 4309379acdcd8abfb72ea89bce3e7746
+ md5sums = 4038939df90f80ea6923d67afff28e03
+
+pkgname = mingw-w64-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c947e6ecf06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+pkgname=mingw-w64-gtk2
+pkgver=2.24.18
+pkgrel=1
+pkgdesc="GTK+ is a multi-platform toolkit (v2) (mingw-w64)"
+arch=(any)
+url="http://www.gtk.org"
+license=("LGPL")
+makedepends=(mingw-w64-gcc mingw-w64-pkg-config)
+depends=(mingw-w64-crt
+mingw-w64-atk
+mingw-w64-pango
+mingw-w64-glib2
+mingw-w64-cairo
+mingw-w64-gdk-pixbuf2)
+options=(!libtool !strip !buildflags)
+source=(
+"http://ftp.gnome.org/pub/gnome/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
+"http://pkgs.fedoraproject.org/cgit/mingw-gtk2.git/plain/gtk-dont-define-initguid.patch?id=3224e445dad240da5f5ebfe371e8c9f627459089")
+md5sums=('4309379acdcd8abfb72ea89bce3e7746'
+ "4038939df90f80ea6923d67afff28e03")
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+build() {
+ cd "${srcdir}/gtk+-${pkgver}"
+ patch -Np0 < '../gtk-dont-define-initguid.patch?id=3224e445dad240da5f5ebfe371e8c9f627459089'
+ for _arch in ${_architectures}; do
+ export CFLAGS="-O2 -mms-bitfields"
+ export CXXFLAGS="${CFLAGS}"
+ unset LDFLAGS
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cp -r "$srcdir/gtk+-$pkgver/"* "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+# if [ $_arch = "x86_64-w64-mingw32" ]; then
+# rm "gtk/gtk.def"
+# fi
+ ${srcdir}/gtk+-${pkgver}/configure \
+ --prefix=/usr/${_arch} \
+ --build=$CHOST \
+ --host=${_arch} \
+ --with-gdktarget=win32 \
+ --disable-modules \
+ --disable-cups \
+ --with-included-loaders=png,bmp,ico,pnm,xpm \
+ --enable-static \
+ --enable-shared \
+ --disable-glibtest
+ make
+ done
+}
+
+package() {
+ for _arch in ${_architectures}; do
+ cd "${srcdir}/${pkgname}-${pkgver}-build-${_arch}"
+ make -j1 DESTDIR="$pkgdir" install
+ find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
+ rm -r "$pkgdir/usr/${_arch}/"{etc,share}
+ done
+}