summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2016-10-21 11:46:14 -0400
committerJameson Pugh2016-10-21 11:46:14 -0400
commit9e8a579ec15af91f203141eba18c6b4768d510de (patch)
tree15dc9fa08001f2fe1f352b803251d07af6757a67
parent497675d47de2b7bcd05ccbf711efae645d667802 (diff)
downloadaur-9e8a579ec15af91f203141eba18c6b4768d510de.tar.gz
v0.8.5
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD49
2 files changed, 21 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6cb645e22db..7851da03476b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,26 @@
# Generated by mksrcinfo v8
-# Tue Aug 30 15:16:46 UTC 2016
+# Fri Oct 21 15:46:04 UTC 2016
pkgbase = octopi
pkgdesc = a powerful Pacman frontend using Qt libs
- pkgver = 0.8.3
- pkgrel = 2
+ pkgver = 0.8.5
+ pkgrel = 1
url = http://octopiproject.wordpress.com
arch = i686
arch = x86_64
license = GPL2
makedepends = qt5-declarative
makedepends = git
- makedepends = qt4
- source = octopi-0.8.3-2.tar.gz::https://github.com/aarnt/octopi/archive/f07959e06ba5033c99a75ef2710dbd56f8d618a1.tar.gz
+ makedepends = knotifications
+ makedepends = alpm_octopi_utils
+ source = octopi-0.8.5-1.tar.gz::https://github.com/aarnt/octopi/archive/4d0bc6caa92eaf9637af8970dd57779208c5281c.tar.gz
source = octopi-repoeditor.desktop
- sha256sums = 2dc9e18c0e8676e6db35d5bbf8462ccd88088e73776538c317df45ca969350e4
+ sha256sums = 7c47ac8e94157a7ee483b249aa45d85c53d410ac588c52477c77c2f3d714d718
sha256sums = 131f16745df685430db55e54ede6da66aed9b02ca00d6d873a002b2a3e1c90ef
pkgname = octopi
pkgdesc = A powerful Pacman frontend using Qt5 libs
depends = qt5-declarative
+ depends = alpm_octopi_utils
optdepends = xterm: for AUR support
optdepends = kdesu: for KDE
optdepends = gksu: for XFCE, Gnome, LXDE, Cinnamon
@@ -29,7 +31,6 @@ pkgname = octopi
optdepends = yaourt: for AUR support
optdepends = octopi-repoeditor: for editing functions
optdepends = octopi-cachecleaner: for cleaning functions
- optdepends = octopi-notifier-qt4: for notifications
optdepends = octopi-notifier-qt5: for notifications
optdepends = octopi-notifier-frameworks: for notifications
optdepends = pacmanlogviewer: to view pacman log files
@@ -39,17 +40,6 @@ pkgname = octopi-pacmanhelper
pkgdesc = Pacman helper for Octopi notifier
depends = qt5-base
-pkgname = octopi-notifier-qt4
- pkgdesc = Notifier for Octopi using Qt4 libs
- depends = octopi-pacmanhelper
- depends = libnotify
- depends = qt4
- optdepends = xfce4-notifyd: for notifications in XFCE
- provides = octopi-notifier
- conflicts = octopi-notifier
- conflicts = octopi-notifier-qt5
- conflicts = octopi-notifier-frameworks
-
pkgname = octopi-notifier-qt5
pkgdesc = Notifier for Octopi using Qt5 libs
depends = octopi-pacmanhelper
@@ -60,6 +50,7 @@ pkgname = octopi-notifier-qt5
conflicts = octopi-notifier
conflicts = octopi-notifier-qt4
conflicts = octopi-notifier-frameworks
+ replaces = octopi-notifier-qt4
pkgname = octopi-notifier-frameworks
pkgdesc = Notifier for Octopi with Knotifications support
diff --git a/PKGBUILD b/PKGBUILD
index a8432f14c3f6..44b8d34d345f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgbase=octopi
-pkgname=('octopi' 'octopi-pacmanhelper' 'octopi-notifier-qt4' 'octopi-notifier-qt5' 'octopi-notifier-frameworks' 'octopi-repoeditor' 'octopi-cachecleaner')
-pkgver=0.8.3
-pkgrel=2
+pkgname=('octopi' 'octopi-pacmanhelper' 'octopi-notifier-qt5' 'octopi-notifier-frameworks' 'octopi-repoeditor' 'octopi-cachecleaner')
+pkgver=0.8.5
+pkgrel=1
# This is the release package so the below _gitcommit variable should (usually) be commented out.
-_gitcommit="f07959e06ba5033c99a75ef2710dbd56f8d618a1"
+_gitcommit="4d0bc6caa92eaf9637af8970dd57779208c5281c"
pkgdesc="a powerful Pacman frontend using Qt libs"
arch=('i686' 'x86_64')
url="http://octopiproject.wordpress.com"
license=('GPL2')
-makedepends=('qt5-declarative' 'git' 'qt4')
+makedepends=('qt5-declarative' 'git' 'knotifications' 'alpm_octopi_utils')
if [ "${_gitcommit}" != "" ]; then
source=("octopi-${pkgver}-${pkgrel}.tar.gz::https://github.com/aarnt/octopi/archive/${_gitcommit}.tar.gz"
'octopi-repoeditor.desktop')
@@ -18,7 +18,7 @@ else
source=("https://github.com/aarnt/${pkgname}/archive/v${pkgver}.tar.gz"
'octopi-repoeditor.desktop')
fi
-sha256sums=('2dc9e18c0e8676e6db35d5bbf8462ccd88088e73776538c317df45ca969350e4'
+sha256sums=('7c47ac8e94157a7ee483b249aa45d85c53d410ac588c52477c77c2f3d714d718'
'131f16745df685430db55e54ede6da66aed9b02ca00d6d873a002b2a3e1c90ef')
prepare() {
@@ -31,7 +31,6 @@ prepare() {
# sed version
sed -i -e "s|0.9.0 (dev)|${pkgver}-${pkgrel}|g" src/strconstants.h
- cp -r notifier notifier-qt4
cp -r notifier notifier-qt5
cp -r notifier notifier-frameworks
sed -i 's|#DEFINES += KSTATUS|DEFINES += KSTATUS|' notifier-frameworks/octopi-notifier/octopi-notifier.pro
@@ -53,11 +52,6 @@ build() {
qmake-qt5 pacmanhelper.pro
make
- cd ../../notifier-qt4/octopi-notifier
- msg "Building octopi-notifier-qt4..."
- qmake-qt4 octopi-notifier.pro
- make
-
cd ../../notifier-qt5/octopi-notifier
msg "Building octopi-notifier-qt5..."
qmake-qt5 octopi-notifier.pro
@@ -81,7 +75,7 @@ build() {
package_octopi() {
pkgdesc="A powerful Pacman frontend using Qt5 libs"
- depends=('qt5-declarative')
+ depends=('qt5-declarative' 'alpm_octopi_utils')
optdepends=('xterm: for AUR support'
'kdesu: for KDE'
'gksu: for XFCE, Gnome, LXDE, Cinnamon'
@@ -92,7 +86,6 @@ package_octopi() {
'yaourt: for AUR support'
'octopi-repoeditor: for editing functions'
'octopi-cachecleaner: for cleaning functions'
- 'octopi-notifier-qt4: for notifications'
'octopi-notifier-qt5: for notifications'
'octopi-notifier-frameworks: for notifications'
'pacmanlogviewer: to view pacman log files')
@@ -133,31 +126,13 @@ package_octopi-pacmanhelper() {
install -Dm644 "notifier/pacmanhelper/polkit/org.octopi.pacmanhelper.service" "${pkgdir}/usr/share/dbus-1/system-services/org.octopi.pacmanhelper.service"
}
-package_octopi-notifier-qt4() {
- pkgdesc="Notifier for Octopi using Qt4 libs"
- depends=('octopi-pacmanhelper' 'libnotify' 'qt4')
- optdepends=('xfce4-notifyd: for notifications in XFCE')
- conflicts=('octopi-notifier' 'octopi-notifier-qt5' 'octopi-notifier-frameworks')
- provides=('octopi-notifier')
-
- if [ "${_gitcommit}" != "" ]; then
- cd "${srcdir}/${pkgbase}-${_gitcommit}"
- else
- cd "${srcdir}/${pkgbase}-${pkgver}"
- fi
-
- #Octopi-notifier files
- install -D -m755 "notifier-qt4/bin/octopi-notifier" "${pkgdir}/usr/bin/octopi-notifier"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
-}
-
package_octopi-notifier-qt5() {
pkgdesc="Notifier for Octopi using Qt5 libs"
depends=('octopi-pacmanhelper' 'libnotify' 'qt5-base')
optdepends=('xfce4-notifyd: for notifications in XFCE')
conflicts=('octopi-notifier' 'octopi-notifier-qt4' 'octopi-notifier-frameworks')
provides=('octopi-notifier')
+ replaces=('octopi-notifier-qt4')
if [ "${_gitcommit}" != "" ]; then
cd "${srcdir}/${pkgbase}-${_gitcommit}"
@@ -167,8 +142,8 @@ package_octopi-notifier-qt5() {
#Octopi-notifier files
install -D -m755 "notifier-qt5/bin/octopi-notifier" "${pkgdir}/usr/bin/octopi-notifier"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
+ install -D -m644 "notifier-qt5/octopi-notifier/octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "notifier-qt5/octopi-notifier/octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
}
package_octopi-notifier-frameworks() {
@@ -187,8 +162,8 @@ package_octopi-notifier-frameworks() {
#Octopi-notifier files
install -D -m755 "notifier-frameworks/bin/octopi-notifier" "${pkgdir}/usr/bin/octopi-notifier"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
+ install -D -m644 "notifier-frameworks/octopi-notifier/octopi-notifier.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "notifier-frameworks/octopi-notifier/octopi-notifier.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
}
package_octopi-repoeditor() {