summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-03-26 18:04:40 -0600
committerMark Wagie2024-03-26 18:04:40 -0600
commitf5cbcabba60d87e648e09805e9c7e6f06ccd3142 (patch)
tree672ba66e70145d0799b33a1c743d43ca9a4b9398
parent0d80325ce84083c895ba56e8f755397d06a6411b (diff)
downloadaur-f5cbcabba60d87e648e09805e9c7e6f06ccd3142.tar.gz
adopt package ...
- correct arch - prepare for split package
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD141
2 files changed, 116 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf85783db008..e4563af79f4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = octopi
- pkgdesc = This is Octopi, a powerful Pacman frontend using Qt libs
pkgver = 0.15.0
- pkgrel = 3
- url = https://tintaescura.com/projects/octopi/
- arch = any
- license = GPL2
+ pkgrel = 4
+ url = https://tintaescura.com/projects/octopi
+ arch = x86_64
+ license = GPL-2.0-or-later
makedepends = qt5-tools
- depends = alpm_octopi_utils
+ source = octopi-0.15.0.tar.gz::https://github.com/aarnt/octopi/archive/v0.15.0.tar.gz
+ sha256sums = e94525d906d6ab4f5fc594cf1a267668ae5f1fa7f32e449ddfa84328dd738f30
+
+pkgname = octopi
+ pkgdesc = A powerful Pacman frontend using Qt libs
+ depends = alpm-octopi-utils
depends = qtermwidget
- depends = sudo
optdepends = octopi-notifier-qt5: Notifier for Octopi using Qt5 libs
optdepends = octopi-notifier-frameworks: Notifier for Octopi with Knotifications support
optdepends = pacaur: for AUR support
@@ -17,10 +20,15 @@ pkgbase = octopi
optdepends = trizen: for AUR support
optdepends = yay: for AUR support
optdepends = pacmanlogviewer: to view pacman log files
- provides = octopi
+ optdepends = opendoas: privilege elevation
+ optdepends = sudo: privilege elevation
provides = octopi-repoeditor
provides = octopi-cachecleaner
- source = octopi::https://github.com/aarnt/octopi/archive/refs/tags/v0.15.0.tar.gz
- sha256sums = e94525d906d6ab4f5fc594cf1a267668ae5f1fa7f32e449ddfa84328dd738f30
-
-pkgname = octopi
+ conflicts = octopi-qt5
+ conflicts = octopi-pacmanhelper
+ conflicts = octopi-repoeditor
+ conflicts = octopi-cachecleaner
+ replaces = octopi-qt5
+ replaces = octopi-pacmanhelper
+ replaces = octopi-repoeditor
+ replaces = octopi-cachecleaner
diff --git a/PKGBUILD b/PKGBUILD
index 5e768052b74a..8bfa82fbda3a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,57 +1,108 @@
-# Maintainer: MatMoul <matmoul at the google email domain which is .com>
-
-_githubuser=aarnt
-_githubrepo=octopi
-_pkgtagname=v0.15.0
-
-pkgname=octopi
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+# Contributor: MatMoul <matmoul at the google email domain which is .com>
+pkgbase=octopi
+pkgname=('octopi'
+# 'octopi-notifier-qt5'
+# 'octopi-notifier-frameworks'
+)
+pkgbase=octopi
pkgver=0.15.0
-pkgrel=3
-pkgdesc='This is Octopi, a powerful Pacman frontend using Qt libs'
-arch=('any')
-url="https://tintaescura.com/projects/octopi/"
-license=('GPL2')
-depends=('alpm_octopi_utils' 'qtermwidget' 'sudo')
+pkgrel=4
+arch=('x86_64')
+url="https://tintaescura.com/projects/octopi"
+license=('GPL-2.0-or-later')
+#depends=('alpm-octopi-utils' 'qtermwidget')
+#makedepends=('qt5-tools' 'knotifications5')
makedepends=('qt5-tools')
-optdepends=('octopi-notifier-qt5: Notifier for Octopi using Qt5 libs'
- 'octopi-notifier-frameworks: Notifier for Octopi with Knotifications support'
- 'pacaur: for AUR support'
- 'paru: for AUR support'
- 'pikaur: for AUR support'
- 'trizen: for AUR support'
- 'yay: for AUR support'
- 'pacmanlogviewer: to view pacman log files')
-provides=('octopi' 'octopi-repoeditor' 'octopi-cachecleaner')
-source=("${_githubrepo}::https://github.com/${_githubuser}/${_githubrepo}/archive/refs/tags/${_pkgtagname}.tar.gz")
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/aarnt/octopi/archive/v${pkgver}.tar.gz")
sha256sums=('e94525d906d6ab4f5fc594cf1a267668ae5f1fa7f32e449ddfa84328dd738f30')
-_subdirs=(helper repoeditor cachecleaner sudo)
+_subdirs=(
+ helper
+# notifier
+# notifier-frameworks
+ repoeditor
+ cachecleaner
+ sudo
+)
prepare() {
- cd "${_githubrepo}-${pkgver}"
- cp resources/images/octopi_green.png resources/images/octopi.png
+ cd "${pkgbase}-${pkgver}"
+
+ # copy notifier folder for building both qt5 & kstatus notifier backends
+# cp -rf notifier notifier-qt5
+# cp -rf notifier notifier-frameworks
+
+ # enable building the kstatus alpm backend for notifier-frameworks
+# sed -i 's|#KSTATUS|KSTATUS|' "notifier-frameworks/${pkgbase}-notifier.pro"
+
+ # why doesn't upstream just do this so we don't have to...
+ cp -f "resources/images/${pkgbase}_green.png" "resources/images/${pkgbase}.png"
}
build() {
- cd "${_githubrepo}-${pkgver}"
- echo "Starting build..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" octopi.pro
- make
- for _subdir in ${_subdirs[@]}; do
- pushd $_subdir
- echo "Building octopi-$_subdir..."
- qmake-qt5 PREFIX=/usr QMAKE_CFLAGS="${CFLAGS}" QMAKE_CXXFLAGS="${CXXFLAGS}" QMAKE_LFLAGS="${LDFLAGS}" "octopi-$_subdir.pro"
- make
- popd
- done
+ cd "${pkgbase}-${pkgver}"
+ qmake-qt5 \
+ PREFIX=/usr \
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" \
+ QMAKE_LFLAGS="${LDFLAGS}"
+ make
+
+ for _subdir in ${_subdirs[@]}; do
+ pushd ${_subdir}
+ qmake-qt5 \
+ PREFIX=/usr \
+ QMAKE_CFLAGS="${CFLAGS}" \
+ QMAKE_CXXFLAGS="${CXXFLAGS}" \
+ QMAKE_LFLAGS="${LDFLAGS}"
+ make
+ popd
+ done
}
-package() {
- cd "${_githubrepo}-${pkgver}"
- make INSTALL_ROOT="${pkgdir}" install
- for _subdir in ${_subdirs[@]}; do
- pushd $_subdir
- make INSTALL_ROOT="${pkgdir}" install
- popd
- done
+package_octopi() {
+ pkgdesc="A powerful Pacman frontend using Qt libs"
+ depends=('alpm-octopi-utils' 'qtermwidget')
+ optdepends=('octopi-notifier-qt5: Notifier for Octopi using Qt5 libs'
+ 'octopi-notifier-frameworks: Notifier for Octopi with Knotifications support'
+ 'pacaur: for AUR support'
+ 'paru: for AUR support'
+ 'pikaur: for AUR support'
+ 'trizen: for AUR support'
+ 'yay: for AUR support'
+ 'pacmanlogviewer: to view pacman log files'
+ 'opendoas: privilege elevation'
+ 'sudo: privilege elevation')
+ provides=('octopi-repoeditor' 'octopi-cachecleaner')
+ conflicts=('octopi-qt5' 'octopi-pacmanhelper' 'octopi-repoeditor' 'octopi-cachecleaner')
+ replaces=('octopi-qt5' 'octopi-pacmanhelper' 'octopi-repoeditor' 'octopi-cachecleaner')
+
+ cd "${pkgbase}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+
+ for folder in helper repoeditor cachecleaner sudo; do
+ make -C ${folder} INSTALL_ROOT="${pkgdir}" install
+ done
}
+
+#package_octopi-notifier-qt5() {
+# pkgdesc="Notifier for Octopi using Qt5 libs"
+# depends=('octopi')
+# provides=('octopi-notifier')
+# conflicts=('octopi-notifier')
+# replaces=('octopi-qt5-notifier' 'octopi-notifier-qt4')
+
+# cd "${pkgbase}-${pkgver}"
+# make -C notifier INSTALL_ROOT="${pkgdir}" install
+#}
+
+#package_octopi-notifier-frameworks() {
+# pkgdesc="Notifier for Octopi with Knotifications support"
+# depends=('octopi' 'knotifications5')
+# provides=('octopi-notifier')
+# conflicts=('octopi-notifier')
+
+# cd "${pkgbase}-${pkgver}"
+# make -C notifier-frameworks INSTALL_ROOT="${pkgdir}" install
+#}