summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-10-19 19:47:50 +0200
committerSefa Eyeoglu2022-10-19 19:47:50 +0200
commit5e3f7134896ca2f084e60bf32f3e68710c4aadfa (patch)
treefc390e83c55eba6a79e6df4f0ba52dc35f8c7ac8
parent78f9e0687675e3ee98f4fd368cb06f00062d7b43 (diff)
downloadaur-5e3f7134896ca2f084e60bf32f3e68710c4aadfa.tar.gz
upgpkg: prismlauncher 5.0-1
upstream release
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 9 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9975e7e2745..e24f2238a41b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = prismlauncher
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 1.4.2
+ pkgver = 5.0
pkgrel = 1
- url = https://github.com/PlaceholderMC/PlaceholderMC
+ url = https://github.com/PrismLauncher/PrismLauncher
arch = i686
arch = x86_64
license = GPL3
@@ -24,9 +24,7 @@ pkgbase = prismlauncher
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
optdepends = xorg-xrandr: for older minecraft versions
- source = https://github.com/PlaceholderMC/PlaceholderMC/releases/download/1.4.2/PlaceholderMC-1.4.2.tar.gz
- source = fix-qt6-4.patch::https://github.com/PlaceholderMC/PlaceholderMC/commit/7ccafdc99321e82ee0f504a573a5c978480374a2.patch
- sha256sums = a66f25e0389815d2419a5b3aa1b85a390f14bbf3997c55c7da1ce4507b5aa511
- sha256sums = 4215ec878ec7a5a63cc5710ef09a66f271d332542f4c6f5bb5f270a924dadcc7
+ source = https://github.com/PrismLauncher/PrismLauncher/releases/download/5.0/PrismLauncher-5.0.tar.gz
+ sha256sums = 27c2c7e0c9aaa3450b7449683cfd2a9a941b7118ab83947de09285438e03c495
pkgname = prismlauncher
diff --git a/PKGBUILD b/PKGBUILD
index cb261411d8c8..0bfda15d4c58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# Maintainer: Yellow <yellow@example.com>
# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
# Maintainer: txtsd <code@ihavea.quest>
# Contributor: Lenny McLennington <lennymclennington@protonmail.com>
@@ -8,11 +7,11 @@
# Contributor: dada513 <dada513@protonmail.com>
pkgname=prismlauncher
-pkgver=1.4.2
+pkgver=5.0
pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
arch=('i686' 'x86_64')
-url="https://github.com/PlaceholderMC/PlaceholderMC"
+url="https://github.com/PrismLauncher/PrismLauncher"
license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc')
@@ -20,16 +19,8 @@ optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
'xorg-xrandr: for older minecraft versions')
-source=("https://github.com/PlaceholderMC/PlaceholderMC/releases/download/$pkgver/PlaceholderMC-$pkgver.tar.gz"
- "fix-qt6-4.patch::https://github.com/PlaceholderMC/PlaceholderMC/commit/7ccafdc99321e82ee0f504a573a5c978480374a2.patch")
-sha256sums=('a66f25e0389815d2419a5b3aa1b85a390f14bbf3997c55c7da1ce4507b5aa511'
- '4215ec878ec7a5a63cc5710ef09a66f271d332542f4c6f5bb5f270a924dadcc7')
-
-prepare() {
- cd "PlaceholderMC-$pkgver"
-
- patch -Np1 -i "../fix-qt6-4.patch"
-}
+source=("https://github.com/PrismLauncher/PrismLauncher/releases/download/$pkgver/PrismLauncher-$pkgver.tar.gz")
+sha256sums=('27c2c7e0c9aaa3450b7449683cfd2a9a941b7118ab83947de09285438e03c495')
build() {
@@ -37,7 +28,7 @@ build() {
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_BUILD_PLATFORM="archlinux" \
-DLauncher_QT_VERSION_MAJOR="6" \
- -Bbuild -SPlaceholderMC-$pkgver
+ -Bbuild -SPrismLauncher-$pkgver
cmake --build build
}