summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2022-11-01 12:10:48 +0100
committerSefa Eyeoglu2022-11-01 12:10:48 +0100
commitfcbb4be4355be3b1f4bd9d42c52e99be0fc13f3a (patch)
treec344306ed23764ee2697403085008cfe6a065713
parenta34f881a041668721e5fb46933885eb6c7d93c5a (diff)
downloadaur-fcbb4be4355be3b1f4bd9d42c52e99be0fc13f3a.tar.gz
upgpkg: prismlauncher 5.1-1
upstream release Update! Signed-off-by: Sefa Eyeoglu <contact@scrumplex.net>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f67dafde64b3..ae76eb9c449d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = prismlauncher
pkgdesc = Minecraft launcher with ability to manage multiple instances.
- pkgver = 5.0
- pkgrel = 5
+ pkgver = 5.1
+ pkgrel = 1
url = https://prismlauncher.org
arch = i686
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cmake
makedepends = extra-cmake-modules
@@ -27,12 +28,7 @@ pkgbase = prismlauncher
optdepends = openal: to use system OpenAL libraries
optdepends = visualvm: Profiling support
optdepends = xorg-xrandr: for older minecraft versions
- provides = prismlauncher
- conflicts = polymc
- conflicts = polymc-qt5
- conflicts = prismlauncher
- conflicts = prismlauncher-qt5
- source = https://github.com/PrismLauncher/PrismLauncher/releases/download/5.0/PrismLauncher-5.0.tar.gz
- sha256sums = 27c2c7e0c9aaa3450b7449683cfd2a9a941b7118ab83947de09285438e03c495
+ source = https://github.com/PrismLauncher/PrismLauncher/releases/download/5.1/PrismLauncher-5.1.tar.gz
+ sha256sums = d5774911c2fde98f6b663c76084e49e8f664a0f21e13da9196072d38191a7d1e
pkgname = prismlauncher
diff --git a/PKGBUILD b/PKGBUILD
index 4eb730612cc0..84e05ed53904 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,39 +7,38 @@
# Contributor: dada513 <dada513@protonmail.com>
pkgname=prismlauncher
-pkgver=5.0
-pkgrel=5
+pkgver=5.1
+pkgrel=1
pkgdesc="Minecraft launcher with ability to manage multiple instances."
-arch=('i686' 'x86_64')
+arch=('i686' 'x86_64' 'aarch64')
url="https://prismlauncher.org"
license=('GPL3')
depends=('java-runtime' 'libgl' 'qt6-base' 'qt6-5compat' 'qt6-svg' 'qt6-imageformats' 'zlib' 'hicolor-icon-theme' 'quazip-qt6')
-provides=('prismlauncher')
-conflicts=('polymc' 'polymc-qt5' 'prismlauncher' 'prismlauncher-qt5')
makedepends=('cmake' 'extra-cmake-modules' 'git' 'java-environment' 'scdoc' 'ghc-filesystem' 'gamemode' 'tomlplusplus')
optdepends=('glfw: to use system GLFW libraries'
'openal: to use system OpenAL libraries'
'visualvm: Profiling support'
'xorg-xrandr: for older minecraft versions')
source=("https://github.com/PrismLauncher/PrismLauncher/releases/download/$pkgver/PrismLauncher-$pkgver.tar.gz")
-sha256sums=('27c2c7e0c9aaa3450b7449683cfd2a9a941b7118ab83947de09285438e03c495')
+sha256sums=('d5774911c2fde98f6b663c76084e49e8f664a0f21e13da9196072d38191a7d1e')
build() {
+ cd "PrismLauncher-$pkgver"
cmake -DCMAKE_BUILD_TYPE= \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DLauncher_BUILD_PLATFORM="archlinux" \
-DLauncher_QT_VERSION_MAJOR="6" \
- -Bbuild -SPrismLauncher-$pkgver
+ -Bbuild -S.
cmake --build build
}
check() {
- cd "build"
+ cd "PrismLauncher-$pkgver/build"
ctest .
}
package() {
- cd "build"
+ cd "PrismLauncher-$pkgver/build"
DESTDIR="$pkgdir" cmake --install .
}