summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgivemeurhats2018-01-19 00:40:53 +0100
committergivemeurhats2018-01-19 00:40:53 +0100
commitd1951c605f60b32ad78c9bd948393db14848a7da (patch)
treee9d6dffdab66216edd941f27229b5e25bd2c4126
downloadaur-d1951c605f60b32ad78c9bd948393db14848a7da.tar.gz
First version of protonmail-desktop package
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
-rw-r--r--protonmail-desktop2
-rw-r--r--protonmail-desktop.desktop10
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3f646d384df
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = protonmail-desktop
+ pkgdesc = Unofficial app that emulates a native client for the ProtonMail e-mail service
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = https://github.com/protonmail-desktop/application
+ arch = any
+ license = GPL3
+ provides = protonmail-desktop
+ source = https://github.com/protonmail-desktop/application/releases/download/v0.5.4/protonmail-desktop-0.5.4.tar.gz
+ source = https://i.imgur.com/hySaVZp.png
+ source = protonmail-desktop.desktop
+ source = protonmail-desktop
+ md5sums = 515731f7f255ae3605f5ca013b14420e
+ md5sums = 3cd502ea0bdb20f99cc8a018084746d4
+ md5sums = 738f1086d70031a262aacf329de0d06c
+ md5sums = 6edb6dd0aad1511978dca145114e87b7
+
+pkgname = protonmail-desktop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7faf966d45e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: givemeurhats <givemeurhats [at] gmail [dot] com>
+
+pkgname=protonmail-desktop
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="Unofficial app that emulates a native client for the ProtonMail e-mail service"
+url="https://github.com/protonmail-desktop/application"
+license=('GPL3')
+arch=('any')
+provides=('protonmail-desktop')
+source=(https://github.com/protonmail-desktop/application/releases/download/v0.5.4/protonmail-desktop-0.5.4.tar.gz
+ https://i.imgur.com/hySaVZp.png
+ protonmail-desktop.desktop
+ protonmail-desktop)
+md5sums=('515731f7f255ae3605f5ca013b14420e'
+ '3cd502ea0bdb20f99cc8a018084746d4'
+ '738f1086d70031a262aacf329de0d06c'
+ '6edb6dd0aad1511978dca145114e87b7')
+
+package() {
+ mkdir -p ${pkgdir}/opt/protonmail-desktop/icons
+ mkdir -p ${pkgdir}/usr/bin
+ mkdir -p ${pkgdir}/usr/share/applications
+ cp -R ${srcdir}/protonmail-desktop-${pkgver}/* ${pkgdir}/opt/protonmail-desktop/
+ cp ${srcdir}/protonmail-desktop ${pkgdir}/usr/bin/
+ cp ${srcdir}/hySaVZp.png ${pkgdir}/opt/protonmail-desktop/icons/protonmail-desktop.png
+ chmod +x ${pkgdir}/usr/bin/protonmail-desktop
+ cp ${srcdir}/protonmail-desktop.desktop ${pkgdir}/usr/share/applications/
+}
diff --git a/protonmail-desktop b/protonmail-desktop
new file mode 100644
index 000000000000..e024217bfb6e
--- /dev/null
+++ b/protonmail-desktop
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/protonmail-desktop/protonmail-desktop
diff --git a/protonmail-desktop.desktop b/protonmail-desktop.desktop
new file mode 100644
index 000000000000..4b8c7284d81d
--- /dev/null
+++ b/protonmail-desktop.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Protonmail
+Comment=Protonmail desktop client
+Exec=/usr/bin/protonmail-desktop
+Icon=/opt/protonmail-desktop/icons/protonmail-desktop.png
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Network;Email;
+MimeType=message/rfc822;x-scheme-handler/mailto;application/x-xpinstall;