summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfdev312024-04-29 19:15:00 +0200
committerfdev312024-04-29 19:15:00 +0200
commit79154e5aa8577bebc914d7048dca4f0a297465e5 (patch)
tree6861e5a26a1df2b81b371a14a0206f3291a9d9cc
parent04abb7a059c51cd450c9719a8cff856f63e60c89 (diff)
downloadaur-79154e5aa8577bebc914d7048dca4f0a297465e5.tar.gz
Version 2.2.15
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b6798e03fb5..551f1108dd9c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pyprland
pkgdesc = Customize your Hyprland with scratchpads, menus, easy monitor layout and other extensions
- pkgver = 2.2.14
+ pkgver = 2.2.15
pkgrel = 1
url = https://github.com/fdev31/pyprland
arch = any
@@ -13,7 +13,7 @@ pkgbase = pyprland
depends = python-aiofiles
provides = pyprland
conflicts = pyprland
- source = git+https://github.com/fdev31/pyprland.git#tag=2.2.14
+ source = git+https://github.com/fdev31/pyprland.git#tag=2.2.15
md5sums = SKIP
pkgname = pyprland
diff --git a/PKGBUILD b/PKGBUILD
index ba6c6ff3abca..e9ccb6eb0215 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Fabien Devaux <fdev31@gmail.com>
# Contributor: Fabien Devaux <fdev31@gmail.com>
pkgname=pyprland
-pkgver=2.2.14
+pkgver=2.2.15
pkgrel=1
pkgdesc="Customize your Hyprland with scratchpads, menus, easy monitor layout and other extensions"
arch=(any)
@@ -21,17 +21,19 @@ noextract=()
md5sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git checkout ${pkgver}
- printf "%s" "$(git describe --tags)"
+ cd "$srcdir/${pkgname%-git}"
+ git checkout ${pkgver}
+ printf "%s" "$(git describe --tags)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
python -m build --wheel --no-isolation
}
package() {
- cd "$srcdir/${pkgname%-git}"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd "$srcdir/${pkgname%-git}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm0644 "scripts/completions/pypr.bash" "$pkgdir/usr/share/bash-completion/completions/pypr"
+ install -Dm0644 "scripts/completions/pypr.zsh" "$pkgdir/usr/share/zsh/site-functions/_pypr"
}