summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPekka Ristola2023-07-12 22:32:49 +0300
committerPekka Ristola2023-07-12 22:32:49 +0300
commit82d5ef3b4f25c1a6dfec4346daa5c146f9c7613c (patch)
tree08ed0dc7a4ddd3d267bc3982d59d0cb020634d44
downloadaur-82d5ef3b4f25c1a6dfec4346daa5c146f9c7613c.tar.gz
Version 0.1.15
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b3769432f1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-bandcamp-api
+ pkgdesc = A simple way to get info from Bandcamp
+ pkgver = 0.1.15
+ pkgrel = 1
+ url = https://github.com/RustyRin/bandcamp-api
+ arch = any
+ license = GPL3
+ depends = python-beautifulsoup4
+ depends = python-demjson3
+ depends = python-html5lib
+ depends = python-lxml
+ depends = python-requests
+ depends = python-setuptools
+ source = https://files.pythonhosted.org/packages/source/b/bandcamp_api/bandcamp_api-0.1.15.tar.gz
+ sha256sums = e299d4880b0e2d7d410508ce8549234b21e71b2437af1dc900515880430ba46e
+
+pkgname = python-bandcamp-api
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a566b78a6bdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+
+_name=bandcamp_api
+pkgname=python-bandcamp-api
+pkgver=0.1.15
+pkgrel=1
+pkgdesc="A simple way to get info from Bandcamp"
+arch=(any)
+url="https://github.com/RustyRin/bandcamp-api"
+license=(GPL3)
+depends=(
+ python-beautifulsoup4
+ python-demjson3
+ python-html5lib
+ python-lxml
+ python-requests
+ python-setuptools
+)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('e299d4880b0e2d7d410508ce8549234b21e71b2437af1dc900515880430ba46e')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}