summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2024-04-27 12:40:17 +0200
committerChristopher Arndt2024-04-27 12:40:17 +0200
commit25d1e97e91aebb0f8245de76ff608b7a67f1ed80 (patch)
tree2b9e89596e7b276e459ec789ce959b0e9b828fd3
parent373eacb2aa0b6092308ef8122c9e7dcdb5c23b26 (diff)
downloadaur-25d1e97e91aebb0f8245de76ff608b7a67f1ed80.tar.gz
Adopted package; new upstream version 3.1.0
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 30 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b270a363631d..572eda3c7b48 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-doc2dash
- pkgdesc = Create docsets for Dash.app-compatible API browser.
- pkgver = 3.0.0
+ pkgdesc = Create docsets for Dash.app/Zeal-compatible API browsers
+ pkgver = 3.1.0
pkgrel = 1
- url = https://doc2dash.readthedocs.io/en/stable/
+ url = https://doc2dash.hynek.me/
arch = any
license = MIT
makedepends = python-hatch-vcs
@@ -16,8 +16,7 @@ pkgbase = python-doc2dash
depends = python-beautifulsoup4
depends = python-click
depends = python-rich
- provides = python-doc2dash
- source = https://files.pythonhosted.org/packages/source/d/doc2dash/doc2dash-3.0.0.tar.gz
- sha256sums = 5456ee60cce489dd03f6e236b2d997f949d17de3a0fce5e6be3c262493efa1ee
+ source = https://files.pythonhosted.org/packages/source/d/doc2dash/doc2dash-3.1.0.tar.gz
+ sha256sums = 37f61c8d8f6a955d2466b9c073eb2bff44cc54352bf817afb48a3ac8aef6d594
pkgname = python-doc2dash
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..df1d240bed57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+python-doc2dash-*.pkg.tar.*
+doc2dash-*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index dead383b8743..e5223e3df307 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Contributor: xantares
-# Maintainer: asuka minato
-pkgname=python-doc2dash
-_name=${pkgname#python-}
-pkgver=3.0.0
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+# Contributor: xantares
+# Contributor: asuka minato
+
+_pkgname=doc2dash
+pkgname=python-$_pkgname
+pkgver=3.1.0
pkgrel=1
-pkgdesc="Create docsets for Dash.app-compatible API browser."
-url="https://doc2dash.readthedocs.io/en/stable/"
+pkgdesc="Create docsets for Dash.app/Zeal-compatible API browsers"
+url='https://doc2dash.hynek.me/'
arch=(any)
-license=('MIT')
-makedepends=(python-hatch-vcs python-hatch-fancy-pypi-readme python-build python-installer python-wheel python-hatchling)
-depends=('python' 'python-attrs' 'python-beautifulsoup4' 'python-click' 'python-rich')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
-https://raw.githubusercontent.com/hynek/doc2dash/41632ffe36c1db309493feaf54fd8d6b814fef85/LICENSE)
-provides=('python-doc2dash')
-sha256sums=('5456ee60cce489dd03f6e236b2d997f949d17de3a0fce5e6be3c262493efa1ee'
- 'db4f023d9e71791480d1ea447361fd87263ecaac5d420be3b5bb36c72e07c5c5')
+license=(MIT)
+makedepends=(python-hatch-vcs python-hatch-fancy-pypi-readme python-build
+ python-installer python-wheel python-hatchling)
+depends=(python python-attrs python-beautifulsoup4 python-click python-rich)
+source=(
+"https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('37f61c8d8f6a955d2466b9c073eb2bff44cc54352bf817afb48a3ac8aef6d594')
build() {
- cd "$_name-$pkgver"
- python -m build --wheel --no-isolation
+ cd $_pkgname-$pkgver
+ python -m build --wheel --no-isolation
}
package() {
- install -Dm644 LI* -t $pkgdir/usr/share/licenses/$pkgname/
- cd "$_name-$pkgver"
- python -m installer --destdir="$pkgdir" dist/*.whl
+ cd $_pkgname-$pkgver
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -vDm 644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}