summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThore Bödecker2023-01-16 11:30:54 +0000
committerThore Bödecker2023-01-16 11:30:54 +0000
commit8e98300231fc92e275a2b2d1c3d26385271e7501 (patch)
tree6d49badcc4ce2bbcc3f4b22ab5fd3da08511d191
parent374cbd05a549858c46a7d9c455eb4b2ec4c0e3a0 (diff)
downloadaur-8e98300231fc92e275a2b2d1c3d26385271e7501.tar.gz
switch to unittest
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c92976f8b546..fc02fc146a71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Maintainer: Thore Bödecker <foxxx0@archlinux.org>
# Contributor: Maikel Wever <maikelwever@gmail.com>
-pkgbase='python-nine'
-_pkgbase="${pkgbase#python-}"
-pkgname=('python-nine')
+pkgname='python-nine'
+_pkgbase="${pkgname#python-}"
pkgver=1.1.0
-pkgrel=5
+pkgrel=6
arch=('any')
pkgdesc="Python 3/2 compatibility library, allowing to add py2 compat to py3 code"
url="https://github.com/nandoflorestan/nine/"
license=('custom')
depends=('python')
makedepends=('python-setuptools')
-source=("https://github.com/nandoflorestan/nine/archive/v${pkgver}.tar.gz")
+source=("${_pkgbase}-${pkgver}.tar.gz::https://github.com/nandoflorestan/nine/archive/v${pkgver}.tar.gz")
sha512sums=('b445cd1f324a0d2045081226fb650eebd8dbc86942faff204c19fffc022f0190fc04abec563b107cb860202d29f08c132056b1098495471fdfda104e57878828')
check() {
cd "${srcdir}/${_pkgbase}-${pkgver}"
- python ./setup.py test
+ python -m unittest discover -vs .
}
package() {