summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2019-05-24 17:18:53 +0000
committerFelix Yan2019-05-24 17:18:53 +0000
commitac5a255210041891d983133f2dd41b9bfa4f7313 (patch)
treeacf70eff9a463eeaba3e4d39a444bfe4ca592b29
downloadaur-ac5a255210041891d983133f2dd41b9bfa4f7313.tar.gz
addpkg: 0.3.5-1
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68a2c6ff014b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=python-pytest-black
+pkgver=0.3.5
+pkgrel=1
+pkgdesc="A pytest plugin to enable format checking with black"
+arch=('any')
+license=('MIT')
+url="https://github.com/shopkeep/pytest-black/"
+depends=('python-black' 'python-pytest')
+makedepends=('python-setuptools-scm')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/shopkeep/pytest-black/archive/$pkgver.tar.gz")
+sha512sums=('a1ab8d7db5fa01539d308d77619284708c206c92174349c60a8fd74f345fb9934566800c0fb0344fb8a5628cffcdb9cdaad5531f03914a8031a8b3d290188b89')
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+
+build() {
+ cd pytest-black-$pkgver
+ python setup.py build
+}
+
+check() {
+ # Hack entry points by installing it
+
+ cd pytest-black-$pkgver
+ python setup.py install --root="$PWD/tmp_install" --optimize=1
+ PYTHONPATH="$PWD/tmp_install/usr/lib/python3.7/site-packages:$PYTHONPATH:$PWD/tests" py.test
+}
+
+package() {
+ cd pytest-black-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+}