summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2022-11-13 02:33:48 -0800
committerxiota2022-11-13 03:15:40 -0800
commite778a313b5202234a2273c5f2ab5772684b121db (patch)
tree050d965fec7e516cd16015e3aff712de434e27fb
parenta3027e52fb358bec4332a2c5307dceda5fa508de (diff)
downloadaur-e778a313b5202234a2273c5f2ab5772684b121db.tar.gz
3.2.7.r8: add detect-renamed patch
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD44
3 files changed, 29 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d3aaace437a..2a1103ffc688 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rsync-reflink-git
- pkgdesc = A fast and versatile file copying tool for remote and local files - git checkout with reflink support
- pkgver = 3.2.7pre1.r2.g00b361db
+ pkgdesc = A fast and versatile file copying tool for remote and local files - with reflink support (git)
+ pkgver = 3.2.7.r8.g74028965
pkgrel = 1
url = https://github.com/WayneD/rsync/issues/153
arch = i686
@@ -24,9 +24,13 @@ pkgbase = rsync-reflink-git
backup = etc/xinetd.d/rsync
source = rsync-git::git+https://github.com/WayneD/rsync
source = https://github.com/WayneD/rsync-patches/raw/master/clone-dest.diff
+ source = https://github.com/WayneD/rsync-patches/raw/master/detect-renamed.diff
+ source = https://github.com/WayneD/rsync-patches/raw/master/detect-renamed-lax.diff
source = rsyncd.conf
sha256sums = SKIP
- sha256sums = 59fbf061d372ef4e6ce9ed89da2cfb8dc7cdbf4a009b99d2b80b17db34e01dac
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 733ccb571721433c3a6262c58b658253ca6553bec79c2bdd0011810bb4f2156b
pkgname = rsync-reflink-git
diff --git a/.gitignore b/.gitignore
index 4c1117c95089..624578c22214 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,6 @@
pkg
src
-*.pkg.*
*.log
-clone-dest.diff
-rsync-git
+*.tar.*
+*.diff
+rsync*
diff --git a/PKGBUILD b/PKGBUILD
index 8dd9a1bfe304..03006b8b5c35 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,52 +1,48 @@
-_pkgname=rsync-git
+_pkgname=rsync
pkgname=rsync-reflink-git
-pkgver=3.2.7pre1.r2.g00b361db
+pkgver=3.2.7.r8.g74028965
pkgrel=1
-pkgdesc='A fast and versatile file copying tool for remote and local files - git checkout with reflink support'
+pkgdesc='A fast and versatile file copying tool for remote and local files - with reflink support (git)'
arch=('i686' 'x86_64')
url='https://github.com/WayneD/rsync/issues/153'
license=('GPL3')
depends=('acl' 'libacl.so' 'lz4' 'openssl' 'perl' 'popt' 'xxhash' 'libxxhash.so' 'zlib' 'zstd')
makedepends=('git' 'python-commonmark')
-provides=('rsync')
-conflicts=('rsync')
+provides=("${_pkgname}")
+conflicts=(${provides[@]})
backup=(
'etc/rsyncd.conf'
'etc/xinetd.d/rsync'
)
source=(
- "$_pkgname"::"git+https://github.com/WayneD/rsync"
+ "${_pkgname}-git"::"git+https://github.com/WayneD/rsync"
'https://github.com/WayneD/rsync-patches/raw/master/clone-dest.diff'
+ 'https://github.com/WayneD/rsync-patches/raw/master/detect-renamed.diff'
+ 'https://github.com/WayneD/rsync-patches/raw/master/detect-renamed-lax.diff'
'rsyncd.conf'
)
sha256sums=(
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'733ccb571721433c3a6262c58b658253ca6553bec79c2bdd0011810bb4f2156b'
)
pkgver() {
- cd "$srcdir/$_pkgname"
-
- if GITTAG="$(git describe --abbrev=0 --tags 2>/dev/null)"; then
- printf '%s.r%s.g%s' \
- "$(sed -e "s/^${_pkgname%%-git}//" -e 's/^[-_/a-zA-Z]\+//' -e 's/[-_+]/./g' <<< ${GITTAG})" \
- "$(git rev-list --count ${GITTAG}..)" \
- "$(git rev-parse --short HEAD)"
- else
- printf '0.r%s.g%s' \
- "$(git rev-list --count master)" \
- "$(git rev-parse --short HEAD)"
- fi
+ cd "$srcdir/${_pkgname}-git"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir/$_pkgname"
- patch -p1 < "$srcdir/clone-dest.diff"
+ cd "$srcdir/${_pkgname}-git"
+ patch -Np1 -F100 -i "$srcdir/clone-dest.diff"
+ patch -Np1 -F100 -i "$srcdir/detect-renamed.diff"
+ patch -Np1 -F100 -i "$srcdir/detect-renamed-lax.diff"
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}-git"
./configure \
--prefix=/usr \
@@ -57,15 +53,13 @@ build() {
}
check() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}-git"
make test
}
package() {
- cd "$srcdir/$_pkgname"
-
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${_pkgname}-git"
make DESTDIR="$pkgdir" install
install -Dm0644 ../rsyncd.conf "$pkgdir/etc/rsyncd.conf"