summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjkhsjdhjs2022-01-08 06:36:52 +0100
committerjkhsjdhjs2022-01-08 06:36:52 +0100
commit0459f0146ed7b59e6589c1771a2120290b06ff90 (patch)
tree8ee518a31a71c12f5be06d5da35953b1225fe552
parent635c0aa9e81419108086e9dbc818c2358093d242 (diff)
downloadaur-0459f0146ed7b59e6589c1771a2120290b06ff90.tar.gz
Multiple improvements
- remove all make dependencies, as they were unnecessary - change source url to github.com instead of ghproxy.com - install rustdesk files to their correct location directly, instead of copying them in the .install script - don't enable and start the rustdesk service on upgrade/install - remove the .install script - various smaller improvements
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD33
-rw-r--r--rustdesk-bin.install44
3 files changed, 19 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dad34f33375..2c1708c7306c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,22 @@
pkgbase = rustdesk-bin
pkgdesc = Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!
pkgver = 1.1.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/rustdesk/rustdesk
- install = rustdesk-bin.install
arch = x86_64
- license = GPLv3
- makedepends = unzip
- makedepends = zip
- makedepends = pkg-config
- makedepends = make
- makedepends = git
- makedepends = cmake
- makedepends = gcc
- makedepends = curl
- makedepends = wget
- makedepends = rust
- makedepends = yasm
- makedepends = nasm
- makedepends = clang
+ license = GPL3
depends = gtk3
depends = xdotool
depends = libxcb
depends = libxfixes
depends = alsa-lib
depends = pulseaudio
- provides = rustdesk-bin
+ provides = rustdesk
conflicts = rustdesk-bin
conflicts = rustdesk
conflicts = rustdesk-git
- noextract = rustdesk-1.1.8-manjaro-arch.pkg.tar.zst
options = !strip
- source = https://ghproxy.com/https://github.com/rustdesk/rustdesk/releases/download/1.1.8/rustdesk-1.1.8-manjaro-arch.pkg.tar.zst
- source = rustdesk-bin.install
+ source = https://github.com/rustdesk/rustdesk/releases/download/1.1.8/rustdesk-1.1.8-manjaro-arch.pkg.tar.zst
sha256sums = 8fe8f3179ebdc8660ffdf70c39386894dc25780183101ef464d99fc97eb881d3
- sha256sums = b6cf25e231687a6caf178a87113b74482354aea2f8a3f6b8b5800169ce55fb10
pkgname = rustdesk-bin
diff --git a/PKGBUILD b/PKGBUILD
index 9b11ce2a19ac..7e1252166291 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
# Maintainer: taotieren <admin@taotieren.com>
+# Co-Maintainer: Leon Möller <jkhsjdhjs at totally dot rip>
pkgname=rustdesk-bin
pkgver=1.1.8
-pkgrel=2
-pkgdesc="Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk! "
+pkgrel=3
+pkgdesc="Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!"
arch=('x86_64')
url="https://github.com/rustdesk/rustdesk"
-license=('GPLv3')
-provides=(${pkgname})
-conflicts=(${pkgname} ${pkgname%-bin} ${pkgname/bin/git} )
-#replaces=(${pkgname})
+license=('GPL3')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname}" "${pkgname%-bin}" "${pkgname/bin/git}")
+# TODO: add dep on libsciter-gtk, remove libsciter-gtk.so from this package
depends=('gtk3' 'xdotool' 'libxcb' 'libxfixes' 'alsa-lib' 'pulseaudio')
-# 'libsciter-gtk-bin'
-makedepends=('unzip' 'zip' 'pkg-config' 'make' 'git' 'cmake' 'gcc' 'curl' 'wget' 'rust' 'yasm' 'nasm' 'clang')
-backup=()
options=('!strip')
-install=${pkgname}.install
-source=("https://ghproxy.com/https://github.com/rustdesk/rustdesk/releases/download/${pkgver}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst"
- "${pkgname}.install")
-sha256sums=('8fe8f3179ebdc8660ffdf70c39386894dc25780183101ef464d99fc97eb881d3'
- 'b6cf25e231687a6caf178a87113b74482354aea2f8a3f6b8b5800169ce55fb10')
-
-noextract=("rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
+source=("$url/releases/download/${pkgver}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
+sha256sums=('8fe8f3179ebdc8660ffdf70c39386894dc25780183101ef464d99fc97eb881d3')
prepare() {
- bsdtar -xf "${srcdir}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst"
+ sed -i "s/^\(Icon=\).*$/\1rustdesk/" "$srcdir/usr/share/rustdesk/files/rustdesk.desktop"
}
package() {
- cp -r "${srcdir}/usr" "${pkgdir}/"
+ install -Dm755 "$srcdir/usr/bin/rustdesk" "$pkgdir/usr/bin/rustdesk"
+ install -Dm755 "$srcdir/usr/lib/rustdesk/libsciter-gtk.so" "$pkgdir/usr/lib/rustdesk/libsciter-gtk.so"
+ install -Dm644 "$srcdir/usr/share/rustdesk/files/rustdesk.png" "$pkgdir/usr/share/icons/hicolor/256x256/apps/rustdesk.png"
+ install -Dm644 "$srcdir/usr/share/rustdesk/files/rustdesk.desktop" "$pkgdir/usr/share/applications/rustdesk.desktop"
+ install -Dm644 "$srcdir/usr/share/rustdesk/files/rustdesk.service" "$pkgdir/usr/lib/systemd/system/rustdesk.service"
}
diff --git a/rustdesk-bin.install b/rustdesk-bin.install
deleted file mode 100644
index eeef34028380..000000000000
--- a/rustdesk-bin.install
+++ /dev/null
@@ -1,44 +0,0 @@
-# arg 1: the new package version
-#pre_install() {
-#}
-
-# arg 1: the new package version
-post_install() {
- # do something here
- cp /usr/share/rustdesk/files/rustdesk.service /etc/systemd/system/rustdesk.service
- cp /usr/share/rustdesk/files/rustdesk.desktop /usr/share/applications/
- systemctl daemon-reload
- systemctl enable rustdesk
- systemctl start rustdesk
- update-desktop-database
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-pre_upgrade() {
- systemctl stop rustdesk || true
-}
-
-# arg 1: the new package version
-# arg 2: the old package version
-post_upgrade() {
- cp /usr/share/rustdesk/files/rustdesk.service /etc/systemd/system/rustdesk.service
- cp /usr/share/rustdesk/files/rustdesk.desktop /usr/share/applications/
- systemctl daemon-reload
- systemctl enable rustdesk
- systemctl start rustdesk
- update-desktop-database
-}
-
-# arg 1: the old package version
-pre_remove() {
- systemctl stop rustdesk || true
- systemctl disable rustdesk || true
- rm /etc/systemd/system/rustdesk.service || true
-}
-
-# arg 1: the old package version
-post_remove() {
- rm /usr/share/applications/rustdesk.desktop || true
- update-desktop-database
-}