summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-08-25 16:32:41 +0800
committertaotieren2021-08-25 16:33:20 +0800
commit452d532fda4344c74e02686d314bee0638016220 (patch)
tree5acc75728ce34408737635edea0c3ab26e2dcf4a
parent8dba003df969b3166512a14e186e55e531a4ba85 (diff)
downloadaur-452d532fda4344c74e02686d314bee0638016220.tar.gz
Update 1.1.8
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
-rw-r--r--rustdesk-bin.install44
3 files changed, 57 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c55f93f91eb..ce28dec4ead3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = rustdesk-bin
pkgdesc = Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!
- pkgver = 1.1.6
+ pkgver = 1.1.8
pkgrel = 1
url = https://github.com/rustdesk/rustdesk
+ install = rustdesk-bin.install
arch = x86_64
license = GPLv3
makedepends = unzip
@@ -28,9 +29,11 @@ pkgbase = rustdesk-bin
conflicts = rustdesk-bin
conflicts = rustdesk
conflicts = rustdesk-git
- noextract = rustdesk-1.1.6-manjaro-arch.pkg.tar.zst
+ noextract = rustdesk-1.1.8-manjaro-arch.pkg.tar.zst
options = !strip
- source = https://github.com/rustdesk/rustdesk/releases/download/1.1.6/rustdesk-1.1.6-manjaro-arch.pkg.tar.zst
- sha256sums = dbfd6ea2e6994f5157f5794049796a06ea94d424c41121f30181e6ff48fbcaa3
+ source = https://download.fastgit.org/rustdesk/rustdesk/releases/download/1.1.8/rustdesk-1.1.8-manjaro-arch.pkg.tar.zst
+ source = rustdesk-bin.install
+ sha256sums = 8fe8f3179ebdc8660ffdf70c39386894dc25780183101ef464d99fc97eb881d3
+ sha256sums = b6cf25e231687a6caf178a87113b74482354aea2f8a3f6b8b5800169ce55fb10
pkgname = rustdesk-bin
diff --git a/PKGBUILD b/PKGBUILD
index b6a89ca37be9..944f85515bbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: taotieren <admin@taotieren.com>
pkgname=rustdesk-bin
-pkgver=1.1.6
+pkgver=1.1.8
pkgrel=1
pkgdesc="Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk! "
arch=('x86_64')
@@ -15,9 +15,11 @@ depends=('gtk3' 'xdotool' 'libxcb' 'libxfixes' 'alsa-lib' 'pulseaudio')
makedepends=('unzip' 'zip' 'pkg-config' 'make' 'git' 'cmake' 'gcc' 'curl' 'wget' 'rust' 'yasm' 'nasm' 'clang')
backup=()
options=('!strip')
-#install=${pkgname}.install
-source=("${url}/releases/download/${pkgver}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
-sha256sums=('dbfd6ea2e6994f5157f5794049796a06ea94d424c41121f30181e6ff48fbcaa3')
+install=${pkgname}.install
+source=("https://download.fastgit.org/rustdesk/rustdesk/releases/download/${pkgver}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst"
+ "${pkgname}.install")
+sha256sums=('8fe8f3179ebdc8660ffdf70c39386894dc25780183101ef464d99fc97eb881d3'
+ 'b6cf25e231687a6caf178a87113b74482354aea2f8a3f6b8b5800169ce55fb10')
noextract=("rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
diff --git a/rustdesk-bin.install b/rustdesk-bin.install
new file mode 100644
index 000000000000..eeef34028380
--- /dev/null
+++ b/rustdesk-bin.install
@@ -0,0 +1,44 @@
+# arg 1: the new package version
+#pre_install() {
+#}
+
+# arg 1: the new package version
+post_install() {
+ # do something here
+ cp /usr/share/rustdesk/files/rustdesk.service /etc/systemd/system/rustdesk.service
+ cp /usr/share/rustdesk/files/rustdesk.desktop /usr/share/applications/
+ systemctl daemon-reload
+ systemctl enable rustdesk
+ systemctl start rustdesk
+ update-desktop-database
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+pre_upgrade() {
+ systemctl stop rustdesk || true
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ cp /usr/share/rustdesk/files/rustdesk.service /etc/systemd/system/rustdesk.service
+ cp /usr/share/rustdesk/files/rustdesk.desktop /usr/share/applications/
+ systemctl daemon-reload
+ systemctl enable rustdesk
+ systemctl start rustdesk
+ update-desktop-database
+}
+
+# arg 1: the old package version
+pre_remove() {
+ systemctl stop rustdesk || true
+ systemctl disable rustdesk || true
+ rm /etc/systemd/system/rustdesk.service || true
+}
+
+# arg 1: the old package version
+post_remove() {
+ rm /usr/share/applications/rustdesk.desktop || true
+ update-desktop-database
+}