summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy MountainJohnson2022-12-16 13:31:55 -0600
committerJeremy MountainJohnson2022-12-16 13:31:55 -0600
commit8cbc82844983f48fdfe911170298ccb8d0d1c062 (patch)
treed20e8a851a5e90b6750ee0db2d84bc76cdcc16dc
parent6c1f1862fc40f912a631063094c831d44b371480 (diff)
downloadaur-8cbc82844983f48fdfe911170298ccb8d0d1c062.tar.gz
compiles succesfully with rust, switching over to that
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d084cc865f6d..2f4ea2a24889 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = suricata
pkgdesc = A high performance Network IDS, IPS and Network Security Monitoring engine
pkgver = 6.0.9
- pkgrel = 2
+ pkgrel = 3
url = https://suricata.io/
install = suricata.install
arch = i686
arch = x86_64
license = GPL2
- makedepends = rustup
+ makedepends = rust
makedepends = clang
depends = hyperscan
depends = jansson
@@ -22,6 +22,7 @@ pkgbase = suricata
depends = python-yaml
optdepends = geoipupdate: GeoIP2 databases
conflicts = suricata-nfqueue
+ conflicts = rustup
backup = etc/suricata/suricata.yaml
backup = etc/suricata/local.yaml
backup = etc/suricata/classification.config
diff --git a/PKGBUILD b/PKGBUILD
index d7912f9cc3fa..d9ce621b23f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,15 @@
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=suricata
pkgver=6.0.9
-pkgrel=2
+pkgrel=3
pkgdesc="A high performance Network IDS, IPS and Network Security Monitoring engine"
arch=('i686' 'x86_64')
url="https://suricata.io/"
license=('GPL2')
-makedepends=('rustup' 'clang')
+makedepends=('rust' 'clang')
depends=('hyperscan' 'jansson' 'libcap-ng' 'libmagic.so' 'libmaxminddb' 'libnet' 'libpcap' 'libyaml' 'lua' 'pcre' 'python-yaml')
optdepends=('geoipupdate: GeoIP2 databases')
-conflicts=('suricata-nfqueue')
+conflicts=('suricata-nfqueue' 'rustup')
install=suricata.install
backup=('etc/suricata/suricata.yaml'
'etc/suricata/local.yaml'
@@ -27,7 +27,6 @@ sha256sums=('3225edcbd0277545b7128df7b71652e6816f3b4978347d2f4fe297d55ed070e8'
'330c93e72a02f4f80972ab1641ee550b32cfdc2f40c78331294bcc009af06d71')
build() {
- export RUSTUP_TOOLCHAIN=1.52.0 # Use rustup and toolchain version to get build to complete
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-clang=/usr/bin/clang --without-docs \