summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeremy MountainJohnson2023-02-20 13:40:29 -0600
committerJeremy MountainJohnson2023-02-20 13:40:29 -0600
commit8f68cb80cc2ac9e7e5d9c2b789c276d3f3e76493 (patch)
treee773532d2860ad4d97d0c03c2d094ee3d0aee3dc
parent1fad94fcbcd69370659ffe8e841c3aaa080f0f8f (diff)
downloadaur-8f68cb80cc2ac9e7e5d9c2b789c276d3f3e76493.tar.gz
update to .10, added ebpf support back
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f274322664a..eda3201e6dea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = suricata
pkgdesc = A high performance Network IDS, IPS and Network Security Monitoring engine
- pkgver = 6.0.9
- pkgrel = 4
+ pkgver = 6.0.10
+ pkgrel = 1
url = https://suricata.io/
install = suricata.install
arch = i686
@@ -29,12 +29,12 @@ pkgbase = suricata
backup = etc/suricata/classification.config
backup = etc/suricata/reference.config
backup = etc/suricata/threshold.config
- source = https://www.openinfosecfoundation.org/download/suricata-6.0.9.tar.gz
- source = https://www.openinfosecfoundation.org/download/suricata-6.0.9.tar.gz.sig
+ source = https://www.openinfosecfoundation.org/download/suricata-6.0.10.tar.gz
+ source = https://www.openinfosecfoundation.org/download/suricata-6.0.10.tar.gz.sig
source = suricata-update.service
source = suricata-update.timer
validpgpkeys = B36FDAF2607E10E8FFA89E5E2BA9C98CCDF1E93A
- sha256sums = 3225edcbd0277545b7128df7b71652e6816f3b4978347d2f4fe297d55ed070e8
+ sha256sums = 59bfd1bf5d9c1596226fa4815bf76643ce59698866c107a26269c481f125c4d7
sha256sums = SKIP
sha256sums = 57505c464d30623c9d6611ca4b5d08a580c0116b20a4280f39c3720a3f369a92
sha256sums = 330c93e72a02f4f80972ab1641ee550b32cfdc2f40c78331294bcc009af06d71
diff --git a/PKGBUILD b/PKGBUILD
index b799b550ec58..b06506c73a34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Amish <contact at via dot aur>
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=suricata
-pkgver=6.0.9
-pkgrel=4
+pkgver=6.0.10
+pkgrel=1
pkgdesc="A high performance Network IDS, IPS and Network Security Monitoring engine"
arch=('i686' 'x86_64')
url="https://suricata.io/"
@@ -21,7 +21,7 @@ backup=('etc/suricata/suricata.yaml'
source=(https://www.openinfosecfoundation.org/download/${pkgname}-${pkgver}.tar.gz{,.sig}
suricata-update.{service,timer})
validpgpkeys=('B36FDAF2607E10E8FFA89E5E2BA9C98CCDF1E93A') # Open Information Security Foundation
-sha256sums=('3225edcbd0277545b7128df7b71652e6816f3b4978347d2f4fe297d55ed070e8'
+sha256sums=('59bfd1bf5d9c1596226fa4815bf76643ce59698866c107a26269c481f125c4d7'
'SKIP'
'57505c464d30623c9d6611ca4b5d08a580c0116b20a4280f39c3720a3f369a92'
'330c93e72a02f4f80972ab1641ee550b32cfdc2f40c78331294bcc009af06d71')
@@ -30,6 +30,7 @@ build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
--with-clang=/usr/bin/clang --without-docs \
+ --enable-ebpf --enable-ebpf-build \
--disable-gccmarch-native --enable-lua --enable-geoip
make
}