summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJSkier212022-01-12 09:13:07 -0600
committerJSkier212022-01-12 09:13:07 -0600
commit9706009aebd6e2408cc2fd1ffdf22878a037c8cc (patch)
treef2fed0ba99959768c48f8d70e4e91053b25d3cd4
parentbecad062ffd3f57b2e8def79bc06ca126e6b6b0a (diff)
downloadaur-9706009aebd6e2408cc2fd1ffdf22878a037c8cc.tar.gz
add ebpf and xdp support with added clang build dep
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 420602751436..1c0856fed9e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = suricata
pkgdesc = A high performance Network IDS, IPS and Network Security Monitoring engine
pkgver = 6.0.4
- pkgrel = 1
+ pkgrel = 2
url = https://suricata.io/
install = suricata.install
arch = i686
arch = x86_64
license = GPL2
makedepends = rustup
+ makedepends = clang
depends = hyperscan
depends = jansson
depends = libcap-ng
diff --git a/PKGBUILD b/PKGBUILD
index 673b55319159..47ab55b100ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
pkgname=suricata
pkgver=6.0.4
-pkgrel=1
+pkgrel=2
pkgdesc="A high performance Network IDS, IPS and Network Security Monitoring engine"
arch=('i686' 'x86_64')
url="https://suricata.io/"
license=('GPL2')
-makedepends=('rustup')
+makedepends=('rustup' 'clang')
depends=('hyperscan' 'jansson' 'libcap-ng' 'libmagic.so' 'libmaxminddb' 'libnet' 'libpcap' 'libyaml' 'lua' 'pcre' 'python-yaml')
optdepends=('geoipupdate: GeoIP2 databases')
conflicts=('python-sphinx' 'suricata-nfqueue') # Issue with doc generation at compile time - https://github.com/OISF/suricata/pull/6123
@@ -30,6 +30,7 @@ build() {
export RUSTUP_TOOLCHAIN=1.52.0 # Use rustup and toolchain version to get build to complete
cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var \
+ --enable-ebpf --enable-ebpf-build --with-clang=/usr/bin/clang \
--disable-gccmarch-native --enable-lua --enable-geoip
make
}