summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2022-04-05 21:28:53 +0200
committerFrederic Bezies2022-04-05 21:28:53 +0200
commit460c7d53d84a35a3d86c55432b4520e35923f132 (patch)
treef9558a241a5528b93eb973e409db4a5c9d567384
parent97d556acf8b12097976e7a75c17f044332ac336b (diff)
downloadaur-460c7d53d84a35a3d86c55432b4520e35923f132.tar.gz
PKGBUILD cleanup and fix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 463fa13182a5..106f7384cc2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = transmission-gtk-git
pkgdesc = Fast, easy, and free BitTorrent client (GTK+ GUI)(Git version from github repository)
- pkgver = 3.00.r918.g738431169
+ pkgver = 3.00.r921.g7ff138250
pkgrel = 1
epoch = 2
url = http://www.transmissionbt.com/
@@ -11,10 +11,12 @@ pkgbase = transmission-gtk-git
makedepends = git
makedepends = cmake
makedepends = gtkmm3
- depends = curl
+ depends = gtkmm3
depends = libevent
depends = libappindicator-gtk3
depends = libnatpmp
+ depends = libb64
+ depends = miniupnpc
optdepends = notification-daemon: Desktop notification support
optdepends = transmission-cli: daemon and web support
provides = transmission-gtk
diff --git a/PKGBUILD b/PKGBUILD
index 34a498acc440..3fcd5cde07b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,14 @@
pkgname=transmission-gtk-git
_pkgname=transmission
-pkgver=3.00.r918.g738431169
+pkgver=3.00.r921.g7ff138250
pkgrel=1
epoch=2
pkgdesc="Fast, easy, and free BitTorrent client (GTK+ GUI)(Git version from github repository)"
arch=('i686' 'x86_64')
url="http://www.transmissionbt.com/"
license=('MIT')
-depends=('curl' 'libevent' 'libappindicator-gtk3' 'libnatpmp')
+depends=('gtkmm3' 'libevent' 'libappindicator-gtk3' 'libnatpmp' 'libb64' 'miniupnpc')
makedepends=('intltool' 'git' 'cmake' 'gtkmm3')
optdepends=('notification-daemon: Desktop notification support'
'transmission-cli: daemon and web support')
@@ -35,11 +35,7 @@ build() {
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DENABLE_CLI=OFF \
- -DENABLE_DAEMON=OFF \
- -DENABLE_GTK=ON \
- -DENABLE_QT=OFF
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo
make
}