summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKimiblock Moe2024-04-17 21:20:42 +0800
committerKimiblock Moe2024-04-17 21:20:42 +0800
commit669cc29f623e91db78247ae7f2a672fb76cc7620 (patch)
tree51983fe18f0519009c4c41b476edfcec3e4e0f66
parent796fdd038145c1ba76fd00eb56092c4929b52844 (diff)
downloadaur-669cc29f623e91db78247ae7f2a672fb76cc7620.tar.gz
Fix a scripting issue
-rw-r--r--PKGBUILD2
-rw-r--r--wechat.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61d62d710cc7..324d0ad33d42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -85,7 +85,7 @@ source_loong64=(
wechat-loong64-${pkgver}.deb::"https://pro-store-packages.uniontech.com/appstore/pool/appstore/c/com.tencent.wechat/com.tencent.wechat_1.0.0.238_arm64.deb"
)
-md5sums=('8552c99740dcb5268af833f7901b07ca'
+md5sums=('8aaf6a0ef362566f3451bb7572f9447b'
'8f4a19a88facd8d7d6d49f2fab94d70c'
'600e74549ce2258c045d5c2f7689ea63'
'f26cf8d88185f54531ad5cd64111cc35'
diff --git a/wechat.sh b/wechat.sh
index ee7066c606b9..5fa034cb2995 100644
--- a/wechat.sh
+++ b/wechat.sh
@@ -229,6 +229,7 @@ function disableSandbox() {
function openDataDir() {
if [[ $@ =~ "--actions" ]] && [[ $@ =~ "opendir" ]]; then
xdg-open "${XDG_DATA_HOME}"/WeChat_Data
+ exit $?
fi
}