summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjguer2023-05-23 00:25:26 +0200
committerjguer2023-05-23 00:25:26 +0200
commitbdf27d67421cfc9e4ca272d2c5b464daf55c7069 (patch)
tree43c1bde78d72f13da1eeda9d5243839f78c17f61
parent628f0f68cdf16d230c96eb55a119dc45adb11dfc (diff)
downloadaur-bdf27d67421cfc9e4ca272d2c5b464daf55c7069.tar.gz
12.0.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ce71af494be..3973e017c89d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = yay
pkgdesc = Yet another yogurt. Pacman wrapper and AUR helper written in go.
- pkgver = 12.0.4
+ pkgver = 12.0.5
pkgrel = 1
url = https://github.com/Jguer/yay
arch = i686
@@ -12,13 +12,13 @@ pkgbase = yay
arch = aarch64
arch = riscv64
license = GPL3
- makedepends = go>=1.17
+ makedepends = go>=1.19
depends = pacman>5
depends = git
optdepends = sudo: privilege elevation
optdepends = doas: privilege elevation
options = !lto
- source = yay-12.0.4.tar.gz::https://github.com/Jguer/yay/archive/v12.0.4.tar.gz
- sha256sums = 3860685304fce224ba21ee4117e297a8a735c990def160827ff4eb7e0eb09bde
+ source = yay-12.0.5.tar.gz::https://github.com/Jguer/yay/archive/v12.0.5.tar.gz
+ sha256sums = 1327fb90aa749c96534e3c34e13a8bea9327600ecaf7382a8e858985bca1c56e
pkgname = yay
diff --git a/PKGBUILD b/PKGBUILD
index fe5796839867..b96625e079c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jguer <pkgbuilds at jguer.space>
pkgname=yay
-pkgver=12.0.4
+pkgver=12.0.5
pkgrel=1
pkgdesc="Yet another yogurt. Pacman wrapper and AUR helper written in go."
arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
@@ -15,14 +15,9 @@ optdepends=(
'sudo: privilege elevation'
'doas: privilege elevation'
)
-makedepends=('go>=1.17')
+makedepends=('go>=1.19')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/Jguer/yay/archive/v${pkgver}.tar.gz")
-sha256sums=('3860685304fce224ba21ee4117e297a8a735c990def160827ff4eb7e0eb09bde')
-
-# With pacman 6 arriving a rebuild of yay will be necessary, if you upgrade pacman without upgrading yay at the same time, yay will not run after.
-# I'm bumping the pkgrel so it shows up on the upgrade list (and will do so when pacman transitions from staging->core)
-# In case you end up with a non-functioning yay after the upgrade follow the
-# instructions on the github page
+sha256sums=('1327fb90aa749c96534e3c34e13a8bea9327600ecaf7382a8e858985bca1c56e')
build() {
export GOPATH="$srcdir"/gopath