aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-10-14 17:39:42 -0700
committerxiota2023-10-14 17:39:42 -0700
commit0b195433c27d752ef668ce418f9b4787231037fc (patch)
treea1004f67e7e24bef8ebc975a0edd1e4500fa03d3 /PKGBUILD
parent2f63ce0a5a6927965e1e29365b36b3d0caf5ef92 (diff)
downloadaur-0b195433c27d752ef668ce418f9b4787231037fc.tar.gz
update config
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD90
1 files changed, 65 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 132db17aad34..bfb177fb7494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,35 @@
# Maintainer:
# Contributor: Andreas Radke <andyrtr@archlinux.org>
-pkgbase=linux-vfio-lts
+_gitname="linux"
+_pkgname="$_gitname-vfio"
+pkgbase="$_pkgname-lts"
pkgver=6.1.57
-pkgrel=1
-pkgdesc='LTS Linux VFIO'
-url="https://www.kernel.org/"
+pkgrel=2
+pkgdesc='LTS Linux'
+url='https://www.kernel.org'
arch=(x86_64)
license=(GPL2)
makedepends=(
- bc libelf pahole cpio perl tar xz
- xmlto python-sphinx python-sphinx_rtd_theme graphviz imagemagick texlive-latexextra
+ bc
+ cpio
+ gettext
+ libelf
+ pahole
+ perl
+ python
+ tar
+ xz
+
+ # htmldocs
+ graphviz
+ imagemagick
+ python-sphinx
+ texlive-latexextra
)
options=('!strip')
_srcname=linux-$pkgver
+_srctag=v$pkgver
source=(
https://cdn.kernel.org/pub/linux/kernel/v${pkgver%%.*}.x/${_srcname}.tar.{xz,sign}
config # the main kernel config file
@@ -27,14 +43,16 @@ source=(
i915-vga-arbiter.patch
)
validpgpkeys=(
- 'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
- '647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
+ ABAF11C65A2970B130ABE3C479BE3E4300411886 # Linus Torvalds
+ 647F28654894E3BD457199BE38DBBDC86092693E # Greg Kroah-Hartman
+ A2FF3A36AAA56654109064AB19802F8B0D70FC30 # Jan Alexander Steffens (heftig)
+ C7E7849466FE2358343588377258734B41C31549 # David Runge <dvzrv@archlinux.org>
)
-# https://www.kernel.org/pub/linux/kernel/v5.x/sha256sums.asc
+# https://www.kernel.org/pub/linux/kernel/v6.x/sha256sums.asc
sha256sums=(
'f9ebfe3ddc5152d87b37e33be30e31875d137433be10a57ce29d2eae7b6e91b1'
'SKIP'
- '34ff5888b26967abe27a2c0a3c8185f5625412b65ddf9221a7d71fdbaae6c356'
+ 'fcf0b005d3cde29b54a61b25bef3efb42a12ac38c039200ac8f4756618270820'
'7bd64ff894475b3415d792ba8466ba7e8f872af56dbf1aeed0d261fe4008b8b5'
'39649dc1dfcb06b411ad124e123769e955a78961b4ea17538c0919a930925549'
@@ -52,8 +70,16 @@ export KBUILD_BUILD_TIMESTAMP="$(date -Ru${SOURCE_DATE_EPOCH:+d @$SOURCE_DATE_EP
prepare() {
cd $_srcname
+ # prevent sphinx errors
+ sed -E \
+ -e 's@^\s+(kvm\.mitigate_smt_rsb=1)$@ \1@' \
+ -i "Documentation/admin-guide/hw-vuln/cross-thread-rsb.rst"
+
+ sed -E \
+ -e 's@\t@ @g' \
+ -i "Documentation/ABI/testing/sysfs-bus-nvdimm"
+
echo "Setting version..."
- scripts/setlocalversion --save-scmversion
echo "-$pkgrel" > localversion.10-pkgrel
echo "${pkgbase#linux}" > localversion.20-pkgname
@@ -61,6 +87,7 @@ prepare() {
for src in "${source[@]}"; do
src="${src%%::*}"
src="${src##*/}"
+ src="${src%.zst}"
[[ $src = *.patch ]] || continue
echo
echo "Applying patch $src..."
@@ -78,20 +105,29 @@ prepare() {
build() {
cd $_srcname
- make htmldocs all
+ make all
+ make htmldocs
}
_package() {
- pkgdesc="The $pkgdesc kernel and modules"
- depends=(coreutils kmod initramfs)
- optdepends=('wireless-regdb: to set the correct wireless channels of your country'
- 'linux-firmware: firmware images needed for some devices')
-
- provides=(VIRTUALBOX-GUEST-MODULES WIREGUARD-MODULE KSMBD-MODULE)
+ pkgdesc="The $pkgdesc kernel and modules (ACS override and i915 VGA arbiter patches)"
+ depends=(
+ coreutils
+ initramfs
+ kmod
+ )
+ optdepends=(
+ 'wireless-regdb: to set the correct wireless channels of your country'
+ 'linux-firmware: firmware images needed for some devices'
+ )
+ provides=(
+ KSMBD-MODULE
+ VIRTUALBOX-GUEST-MODULES
+ WIREGUARD-MODULE
+ )
cd $_srcname
- local kernver="$(<version)"
- local modulesdir="$pkgdir/usr/lib/modules/$kernver"
+ local modulesdir="$pkgdir/usr/lib/modules/$(<version)"
echo "Installing boot image..."
# systemd expects to find the kernel here to allow hibernation
@@ -102,7 +138,7 @@ _package() {
echo "$pkgbase" | install -Dm644 /dev/stdin "$modulesdir/pkgbase"
echo "Installing modules..."
- make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
+ ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod
# remove build and source links
@@ -110,7 +146,7 @@ _package() {
}
_package-headers() {
- pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel"
+ pkgdesc="Headers and scripts for building modules for the $pkgdesc kernel (ACS override and i915 VGA arbiter patches)"
depends=(pahole)
cd $_srcname
@@ -171,7 +207,7 @@ _package-headers() {
echo "Stripping build tools..."
local file
while read -rd '' file; do
- case "$(file -bi "$file")" in
+ case "$(file -Sib "$file")" in
application/x-sharedlib\;*) # Libraries (.so)
strip -v $STRIP_SHARED "$file" ;;
application/x-archive\;*) # Libraries (.a)
@@ -192,7 +228,7 @@ _package-headers() {
}
_package-docs() {
- pkgdesc="Documentation for the $pkgdesc kernel"
+ pkgdesc="Documentation for the $pkgdesc kernel (ACS override and i915 VGA arbiter patches)"
cd $_srcname
local builddir="$pkgdir/usr/lib/modules/$(<version)/build"
@@ -210,7 +246,11 @@ _package-docs() {
ln -sr "$builddir/Documentation" "$pkgdir/usr/share/doc/$pkgbase"
}
-pkgname=("$pkgbase" "$pkgbase-headers" "$pkgbase-docs")
+pkgname=(
+ "$pkgbase"
+ "$pkgbase-headers"
+ "$pkgbase-docs"
+)
for _p in "${pkgname[@]}"; do
eval "package_$_p() {
$(declare -f "_package${_p#$pkgbase}")