summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de07fc55e3f5..38bceea76810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
# Maintainer: Allen Zhong <allen@moe.cat>
# Contributor: Feishu Linux Team <contact@feishu.cn>
pkgname=feishu-bin
-pkgver=5.4.13
+pkgver=5.9.18
#_pkgrel=24
-_pkgtyp=dev
-_pkghash=e734d9e40e6a
+_pkgtyp=stable
+_pkghash=5db94058d7ad
pkgrel=1
pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
@@ -18,7 +18,7 @@ provides=('bytedance-feishu' 'feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("https://sf3-cn.feishucdn.com/obj/ee-appcenter/${_pkghash}/Feishu-linux_x64-${pkgver}.deb")
-sha256sums=('26dddc20e13f733640dbf8669f4dc24f8c098d5db71f9f86ffe33546a68a5986')
+sha256sums=('ffb29b5a184b025d4e4ea468a8f684a7067ab5bfd45867abc370e59be63892c7')
package(){
# Extract package data
@@ -28,12 +28,15 @@ package(){
cd "${pkgdir}"
ln -s bytedance-feishu-${_pkgtyp} usr/bin/feishu
sed -i "s/bytedance-feishu-${_pkgtyp}/feishu/g" "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i "s/bytedance-feishu/feishu/g" "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i 's/StartupNotify=true/StartupNotify=true\nStartupWMClass=bytedance-feishu/g' "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
sed -i "s/bytedance-feishu/feishu/g" "${pkgdir}/usr/share/menu/bytedance-feishu.menu"
sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/usr/share/appdata/bytedance-feishu.appdata.xml"
+ sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/opt/bytedance/feishu/bytedance-feishu"
mv "${pkgdir}"/usr/share/menu/{bytedance-,}feishu.menu
mv "${pkgdir}"/usr/share/applications/{bytedance-,}feishu.desktop
mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
- mv "${pkgdir}"/usr/share/man/man1/{bytedance-,}feishu.1.gz
+ mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu-${_pkgtyp},feishu}.1.gz
mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-${_pkgtyp},feishu}
# Fix directory permissions