summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc3e2d317991..ae2d2976e136 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Generated by debtap
# Maintainer: Allen Zhong <allen@moe.cat>
-pkgname=bytedance-feishu-stable-bin
+# Contributor: Feishu Linux Team <contact@feishu.cn>
+pkgname=feishu-bin
pkgver=4.3.0
_pkgrel=49
pkgrel=1
-pkgdesc="飞书Linux版本. 飞书整合即时消息、日历、音视频会议、云文档、工作台等功能于一体,成就团队和个人,更高效、更愉悦。"
+pkgdesc="Linux client of Feishu (Lark) from Bytedance."
arch=('x86_64')
url="https://www.feishu.cn/"
license=('unknown')
groups=('')
-depends=('ca-certificates' 'libx11' 'libxtst')
-#optdepends=('android-emulator'
-# 'libu2f-udev')
+depends=('ca-certificates' 'libx11' 'libxcb' 'libxtst' 'nss' 'xdg-utils')
+replaces=('bytedance-feishu-stable-bin')
+provides=('bytedance-feishu')
options=('!strip' '!emptydirs')
install=${pkgname}.install
source=("file://bytedance-feishu_${pkgver}-${_pkgrel}_amd64.deb")
@@ -20,4 +21,17 @@ sha256sums=('fbd28428ec3df298a03b7bf61d140b8533b16b4506e7a6ba73395ba5b807deef')
package(){
# Extract package data
tar xpvf "${srcdir}/data.tar.xz" --xattrs-include='*' --numeric-owner -C "${pkgdir}"
+
+ # Modify files
+ cd "${pkgdir}"
+ ln -s bytedance-feishu-stable usr/bin/feishu
+ sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/applications/bytedance-feishu.desktop"
+ sed -i 's/bytedance-feishu-stable/feishu/g' "${pkgdir}/usr/share/menu/bytedance-feishu.menu"
+ sed -i 's/bytedance-feishu/feishu/g' "${pkgdir}/usr/share/appdata/bytedance-feishu.appdata.xml"
+ mv "${pkgdir}"/usr/share/menu/{bytedance-,}feishu.menu
+ mv "${pkgdir}"/usr/share/applications/{bytedance-,}feishu.desktop
+ mv "${pkgdir}"/usr/share/appdata/{bytedance-,}feishu.appdata.xml
+ mv "${pkgdir}"/usr/share/man/man1/{bytedance-feishu-stable,feishu}.1.gz
+ rm "${pkgdir}"/usr/share/man/man1/bytedance-feishu.1.gz
+ mv "${pkgdir}"/usr/share/doc/{bytedance-feishu-stable,feishu}
}