summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordreieck2022-10-16 14:15:59 +0200
committerdreieck2022-10-16 14:15:59 +0200
commit725296c8888d72adfaf8dea84cbdf8e393dc9245 (patch)
treed688280769faba8c8a115d3e5373db767c87ee25
parent4478d0a0d35a3fd5c352de1cc473249890177a69 (diff)
downloadaur-725296c8888d72adfaf8dea84cbdf8e393dc9245.tar.gz
Now calculating the git revision and commit date and hash correctly from the upstream repository, and not errorneously from the AUR repository.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f6cb249694e..6631c748ca8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = adhocspot-script-git
pkgdesc = Bash script to easily configure your interface to share your internet connection and configure a DHCP and DNS and TFTP boot server to listen on it. IP, DHCP, DNS can be configured, and for WiFi interfaces also wireless mode and encryption.
- pkgver = 20221016.01+r5.20220207.a6f3c78
+ pkgver = 20221016.01.r14.20221016.81f5146
pkgrel = 1
epoch = 0
url = https://gitlab.com/dreieckli/adhocspot-script
@@ -14,7 +14,7 @@ pkgbase = adhocspot-script-git
depends = net-tools
depends = wireless_tools
depends = wpa_supplicant
- provides = adhocspot-script=20221016.01+r5.20220207.a6f3c78
+ provides = adhocspot-script=20221016.01.r14.20221016.81f5146
conflicts = adhocspot-script
options = emptydirs
source = adhocspot-script::git+https://gitlab.com/dreieckli/adhocspot-script.git
diff --git a/PKGBUILD b/PKGBUILD
index 866be77177b8..1a94c57bd2f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=adhocspot-script
pkgname="${_pkgname}-git"
epoch=0
-pkgver=20221016.01+r5.20220207.a6f3c78
+pkgver=20221016.01.r14.20221016.81f5146
pkgrel=1
pkgdesc="Bash script to easily configure your interface to share your internet connection and configure a DHCP and DNS and TFTP boot server to listen on it. IP, DHCP, DNS can be configured, and for WiFi interfaces also wireless mode and encryption."
url="https://gitlab.com/dreieckli/adhocspot-script"
@@ -41,7 +41,9 @@ prepare() {
}
pkgver() {
- _ver="$("${srcdir}/${_pkgname}/adhocspot.sh" --version)"
+ cd "${srcdir}/${_pkgname}"
+
+ _ver="$(./adhocspot.sh --version)"
_rev="$(git rev-list --count HEAD)"
_date="$(git log -1 --date=format:"%Y%m%d" --format="%ad")"
_hash="$(git rev-parse --short HEAD)"
@@ -50,7 +52,7 @@ pkgver() {
error "Version could not be determined."
return 1
else
- printf '%s' "${_ver}+r${_rev}.${_date}.${_hash}"
+ printf '%s' "${_ver}.r${_rev}.${_date}.${_hash}"
fi
}