summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2024-01-15 11:32:12 +0100
committerKlaus Alexander Seistrup2024-01-15 11:32:12 +0100
commit5a9bbddc70dcd02ec7677de2458b180b003a0c15 (patch)
treeb6a6191d3a0d9812fbd6f7313ecb6b074fd61919
parentfbfb7df776b6d4b4fc10cf998cae0df9fe83ee1d (diff)
downloadaur-5a9bbddc70dcd02ec7677de2458b180b003a0c15.tar.gz
RFC-23 is only valid for x86_64 (and i386)
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9e621961e73..475b107584ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bc-gh
pkgdesc = Implementation of dc and POSIX bc with GNU extensions
pkgver = 6.7.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/gavinhoward/bc
arch = aarch64
arch = arm
@@ -15,6 +15,7 @@ pkgbase = bc-gh
provides = bc
conflicts = bc
options = lto
+ options = !makeflags
source = bc-gh-6.7.5.tar.xz::https://github.com/gavinhoward/bc/releases/download/6.7.5/bc-6.7.5.tar.xz
source = bc-gh-6.7.5.tar.xz.sig::https://github.com/gavinhoward/bc/releases/download/6.7.5/bc-6.7.5.tar.xz.sig
validpgpkeys = FF360647C7A7147F27DAAEC1B132F881C306590A
diff --git a/PKGBUILD b/PKGBUILD
index 9669f0eab92c..3fffd186b3f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname='bc-gh'
pkgver=6.7.5
-pkgrel=2
+pkgrel=3
pkgdesc='Implementation of dc and POSIX bc with GNU extensions'
arch=('aarch64' 'arm' 'armv6h' 'armv7h' 'i686' 'x86_64')
url='https://github.com/gavinhoward/bc'
@@ -12,7 +12,7 @@ license=('BSD')
provides=('bc')
conflicts=('bc')
depends=('glibc' 'libedit')
-options=('lto')
+options=('lto' '!makeflags')
source=(
"$pkgname-$pkgver.tar.xz::$url/releases/download/$pkgver/bc-$pkgver.tar.xz"
"$pkgname-$pkgver.tar.xz.sig::$url/releases/download/$pkgver/bc-$pkgver.tar.xz.sig"
@@ -32,7 +32,14 @@ build() {
# RFC-0023
# 🔗 https://rfc.archlinux.page/0023-pack-relative-relocs/
- export LDFLAGS="$LDFLAGS -Wl,-z,pack-relative-relocs"
+ #
+ # ld(1) says: “Supported for i386 and x86-64.”
+ case "${CARCH:-unknown}" in
+ 'x86_64' | 'i386' )
+ export LDFLAGS="$LDFLAGS -Wl,-z,pack-relative-relocs"
+ ;;
+ * ) : pass ;;
+ esac
env CFLAGS="$CFLAGS -O3" \
PREFIX=/usr ./configure.sh -p GNU -e -G -sbc.banner -sdc.tty_mode