summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2023-12-16 13:47:50 +0300
committerCaleb Maclennan2023-12-16 13:47:50 +0300
commit2f3649aa78a4fbdf9ce3e8fe2cda24dc0a5520ee (patch)
tree780d90470498d4847e4329a6c6f44c02ed985911
parent31b1ba2a292537f02e5a5e962a994da2e82906e6 (diff)
downloadaur-2f3649aa78a4fbdf9ce3e8fe2cda24dc0a5520ee.tar.gz
upgpkg: calibre-git 7.2.0.r2.g96211be30e-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD20
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9135ab3d2287..77a235a7613c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = calibre-git
pkgdesc = Ebook management application
- pkgver = 6.22.0.r1.gca2b4e02ed
+ pkgver = 7.2.0.r2.g96211be30e
pkgrel = 1
url = https://calibre-ebook.com
arch = x86_64
@@ -51,6 +51,7 @@ pkgbase = calibre-git
depends = python-pyqt6-webengine
depends = python-regex
depends = python-unrardll
+ depends = python-xxhash
depends = python-zeroconf
depends = qt6-imageformats
depends = qt6-svg
@@ -61,7 +62,7 @@ pkgbase = calibre-git
optdepends = poppler: required for converting pdf to html
optdepends = python-fonttools: required for font subset feature in epub editor
optdepends = speech-dispatcher: TTS support in the viewer
- provides = calibre=6.22.0.r1.gca2b4e02ed
+ provides = calibre=7.2.0.r2.g96211be30e
conflicts = calibre
conflicts = calibre-common
conflicts = calibre-python3
diff --git a/PKGBUILD b/PKGBUILD
index 3350ce85bc5b..0d1adc65283a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
-# Contributor: Eli Schwartz <eschwartz@archlinux.org>
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Jelle van der Waa <jelle@vdwaa.nl>
# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
@@ -7,9 +7,8 @@
# Contributor: Andrea Fagiani <andfagiani _at_ gmail dot com>
# Contributor: Larry Hajali <larryhaja@gmail.com>
-pkgbase=calibre-git
pkgname=calibre-git
-pkgver=6.22.0.r1.gca2b4e02ed
+pkgver=7.2.0.r2.g96211be30e
pkgrel=1
pkgdesc='Ebook management application'
arch=(x86_64 i686)
@@ -42,6 +41,7 @@ _pydeps=(apsw
pyqt6-webengine
regex
unrardll
+ xxhash
zeroconf)
depends=(hunspell
hyphen
@@ -77,8 +77,8 @@ conflicts=("${pkgname%-git}"
calibre-python3)
replaces=(calibre-common-git
calibre-python3-git)
-source=("git+https://github.com/kovidgoyal/${pkgbase%-git}.git?signed"
- "git+https://github.com/kovidgoyal/${pkgbase%-git}-translations.git?signed"
+source=("git+https://github.com/kovidgoyal/${pkgname%-git}.git?signed"
+ "git+https://github.com/kovidgoyal/${pkgname%-git}-translations.git?signed"
user-agent-data.json)
sha256sums=('SKIP'
'SKIP'
@@ -86,12 +86,12 @@ sha256sums=('SKIP'
validpgpkeys=('3CE1780F78DD88DF45194FD706BC317B515ACE7C') # Kovid Goyal (New longer key) <kovid@kovidgoyal.net>
pkgver() {
- cd "${pkgbase%-git}"
+ cd "${pkgname%-git}"
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare(){
- cd "${pkgbase%-git}"
+ cd "${pkgname%-git}"
python setup.py git_version
# Link translations to build dir
@@ -109,7 +109,7 @@ prepare(){
}
build() {
- cd "${pkgbase%-git}"
+ cd "${pkgname%-git}"
export LANG='en_US.UTF-8'
python setup.py build
python setup.py iso639
@@ -121,13 +121,13 @@ build() {
}
check() {
- cd "${pkgbase%-git}"
+ cd "${pkgname%-git}"
export LANG='en_US.UTF-8'
python -m unittest discover
}
package() {
- cd "${pkgbase%-git}"
+ cd "${pkgname%-git}"
export LANG='en_US.UTF-8'
# If this directory doesn't exist, zsh completion won't install.