summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRui Ventura2019-09-05 08:36:41 +0100
committerRui Ventura2019-09-05 08:36:41 +0100
commit999ef5aa1e61f8ba0cf0f87f54cb62ec65dcd720 (patch)
treef1d5420cd78c20accf6abf3c0a20a9815e712d04
downloadaur-999ef5aa1e61f8ba0cf0f87f54cb62ec65dcd720.tar.gz
Initial package submission
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD24
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..483b7a7a758a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = chiaki
+ pkgdesc = Free and Open Source PS4 Remote Play Client
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/thestr4ng3r/chiaki
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = python-protobuf
+ depends = qt5-multimedia
+ depends = qt5-svg
+ depends = ffmpeg
+ depends = libopusenc
+ depends = openssl>=1.1
+ depends = protobuf
+ provides = chiaki
+ source = chiaki.tar.gz::https://github.com/thestr4ng3r/chiaki/releases/download/v1.0.2/chiaki-v1.0.2-src.tar.gz
+ sha256sums = 5effc6ad49fa1bd190fa857fba8a0ad21ca61e251dcbd79c580659f1d16ba85b
+
+pkgname = chiaki
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7329ba7244dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc67c5bf8316
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Rui Ventura <rventura.pt@outlook.com>
+pkgname=chiaki
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Free and Open Source PS4 Remote Play Client'
+arch=('x86_64')
+url='https://github.com/thestr4ng3r/chiaki'
+license=('GPL')
+provides=('chiaki')
+depends=('qt5-multimedia' 'qt5-svg' 'ffmpeg' 'libopusenc' 'openssl>=1.1' 'protobuf')
+makedepends=('cmake' 'python-protobuf')
+source=("$pkgname.tar.gz::$url/releases/download/v$pkgver/$pkgname-v$pkgver-src.tar.gz")
+sha256sums=('5effc6ad49fa1bd190fa857fba8a0ad21ca61e251dcbd79c580659f1d16ba85b')
+
+build() {
+ cd "$srcdir/$pkgname"
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+}