summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothée Ravier2013-11-03 19:42:41 +0100
committerTimothée Ravier2013-11-03 19:42:41 +0100
commit4a82b93130427e5784eb0f4cedfde2ba68f0d326 (patch)
tree64f708255c0b271e8ca0efd742a7d20e24a0673d
downloadaur-4a82b93130427e5784eb0f4cedfde2ba68f0d326.tar.gz
General update: SELinux userspace & pkg renaming
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD38
-rw-r--r--coreutils.install17
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a93a414e89c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = coreutils-selinux
+ pkgdesc = The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support
+ pkgver = 8.21
+ pkgrel = 2
+ url = http://www.gnu.org/software/coreutils
+ install = coreutils.install
+ arch = i686
+ arch = x86_64
+ groups = selinux
+ license = GPL3
+ depends = glibc
+ depends = pam-selinux
+ depends = acl
+ depends = gmp
+ depends = libcap
+ depends = libselinux
+ provides = coreutils=8.21-
+ conflicts = coreutils
+ source = ftp://ftp.gnu.org/gnu/coreutils/coreutils-8.21.tar.xz
+ source = ftp://ftp.gnu.org/gnu/coreutils/coreutils-8.21.tar.xz.sig
+ md5sums = 065ba41828644eca5dd8163446de5d64
+ md5sums = SKIP
+
+pkgname = coreutils-selinux
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d22fff3aedc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+# SELinux Maintainer: Timothée Ravier <tim@siosm.fr>
+# SELinux Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
+
+pkgname=coreutils-selinux
+pkgver=8.21
+pkgrel=2
+pkgdesc="The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support"
+arch=('i686' 'x86_64')
+license=('GPL3')
+url="http://www.gnu.org/software/coreutils"
+groups=('selinux')
+depends=('glibc' 'pam-selinux' 'acl' 'gmp' 'libcap' 'libselinux')
+install=${pkgname/-selinux}.install
+conflicts=("${pkgname/-selinux}")
+provides=("${pkgname/-selinux}=${pkgver}-${pkrel}")
+source=(ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz{,.sig})
+md5sums=('065ba41828644eca5dd8163446de5d64'
+ 'SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname/-selinux}-${pkgver}
+ ./configure --prefix=/usr --libexecdir=/usr/lib \
+ --enable-no-install-program=groups,hostname,kill,uptime
+ make
+}
+
+check() {
+ cd ${srcdir}/${pkgname/-selinux}-${pkgver}
+ #make RUN_EXPENSIVE_TESTS=yes check
+}
+
+package() {
+ cd ${srcdir}/${pkgname/-selinux}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
diff --git a/coreutils.install b/coreutils.install
new file mode 100644
index 000000000000..22cfcb2a113d
--- /dev/null
+++ b/coreutils.install
@@ -0,0 +1,17 @@
+infodir=usr/share/info
+file=coreutils.info
+
+post_install() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [[ -x usr/bin/install-info ]] || return 0
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+}
+