summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12021-12-07 01:54:13 +0800
committerChocobo12021-12-07 02:33:22 +0800
commitb6ed1ccfd901b1d2c30a57a197a543e8fa5966c6 (patch)
tree02184276eb41011dbfcfe68315e8c1dad9155f14
parentc5a820d22542ee4cdec449313a11eb9fac43f243 (diff)
downloadaur-b6ed1ccfd901b1d2c30a57a197a543e8fa5966c6.tar.gz
updpkg: cpio-git 2.13.r15.g86dacfe-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--gettext-version.patch12
3 files changed, 28 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1321eb54fe20..4606c06c4cdb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
pkgbase = cpio-git
pkgdesc = Utility that copy files into or out of a cpio or tar archive
- pkgver = 2.12.r15.g068f5db
+ pkgver = 2.13.r15.g86dacfe
pkgrel = 1
url = https://www.gnu.org/software/cpio/
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ makedepends = rsync
depends = glibc
provides = cpio
conflicts = cpio
source = git+https://git.savannah.gnu.org/git/cpio.git
+ source = gettext-version.patch
sha256sums = SKIP
+ sha256sums = 90ed0528fcc541ab83b3d9c97522bf7b8196a2da8dd60278656158806ee23599
pkgname = cpio-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3fe2767d0a2f..415a84f7ee7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,28 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=cpio-git
-pkgver=2.12.r15.g068f5db
+pkgver=2.13.r15.g86dacfe
pkgrel=1
pkgdesc="Utility that copy files into or out of a cpio or tar archive"
arch=('i686' 'x86_64')
url="https://www.gnu.org/software/cpio/"
license=('GPL')
depends=('glibc')
-makedepends=('git')
+makedepends=('git' 'rsync')
provides=('cpio')
conflicts=('cpio')
-source=("git+https://git.savannah.gnu.org/git/cpio.git")
-sha256sums=('SKIP')
+source=("git+https://git.savannah.gnu.org/git/cpio.git"
+ "gettext-version.patch")
+sha256sums=('SKIP'
+ '90ed0528fcc541ab83b3d9c97522bf7b8196a2da8dd60278656158806ee23599')
+prepare() {
+ cd "cpio"
+
+ patch -Np1 -i "$srcdir/gettext-version.patch"
+}
+
pkgver() {
cd "cpio"
diff --git a/gettext-version.patch b/gettext-version.patch
new file mode 100644
index 000000000000..d161e2695735
--- /dev/null
+++ b/gettext-version.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index 0a35e4c..6c587a0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -84,7 +84,7 @@ AC_CHECK_DECLS([errno, getpwnam, getgrnam, getgrgid, strdup, strerror, getenv, a
+ # Gettext.
+ AM_ICONV
+ AM_GNU_GETTEXT([external], [need-formatstring-macros])
+-AM_GNU_GETTEXT_VERSION(0.19)
++AM_GNU_GETTEXT_VERSION(0.20)
+
+ LIBS="$LIBS $LIB_CLOCK_GETTIME"