aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVufa2022-03-20 15:39:54 +0800
committerVufa2022-03-20 15:39:54 +0800
commita43b5946dbc51b93443b791c46d79273c847a402 (patch)
tree945e1f60503853783097e79d9a05d7fb33b8cbd7
parente1f640cf7e8097ca2c8bfb524dd53c10adb71fbe (diff)
downloadaur-a43b5946dbc51b93443b791c46d79273c847a402.tar.gz
Upgrade WeChat to 3.6.0.18 and upgrade deepin base package to 3.4.0.38deepin6
Signed-off-by: Vufa <countstarlight@gmail.com>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
-rw-r--r--README.md3
-rwxr-xr-xrun.sh4
4 files changed, 24 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 398a2b5305ae..6e8006c34601 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deepin-wine-wechat
pkgdesc = Tencent WeChat on Deepin Wine(com.qq.weixin.deepin) For Archlinux
- pkgver = 3.5.0.46
- pkgrel = 3
+ pkgver = 3.6.0.18
+ pkgrel = 1
url = https://weixin.qq.com/
install = deepin-wine-wechat.install
arch = x86_64
@@ -20,15 +20,15 @@ pkgbase = deepin-wine-wechat
optdepends = noto-fonts-sc: display some Chinese characters
optdepends = lib32-nvidia-utils: required for nvidia graphics card
conflicts = deepin-wechat
- source = https://com-store-packages.uniontech.com/appstore/pool/appstore/c/com.qq.weixin.deepin/com.qq.weixin.deepin_3.4.0.38deepin4_i386.deb
- source = WeChatSetup-3.5.0.46.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
+ source = https://com-store-packages.uniontech.com/appstore/pool/appstore/c/com.qq.weixin.deepin/com.qq.weixin.deepin_3.4.0.38deepin6_i386.deb
+ source = WeChatSetup-3.6.0.18.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
source = https://community-packages.deepin.com/deepin/pool/main/o/openldap/libldap-2.4-2_2.4.47+dfsg.4-1+eagle_i386.deb
- source = https://community-packages.deepin.com/deepin/pool/main/c/cyrus-sasl2/libsasl2-2_2.1.27+dfsg-1+deb10u1_i386.deb
+ source = https://community-packages.deepin.com/deepin/pool/main/c/cyrus-sasl2/libsasl2-2_2.1.27.1-1+dde_i386.deb
source = run.sh
- md5sums = 940b59d57536a1e43bc9fc6f61d675ca
- md5sums = d81ce735e25cf79ac90bdc2c87020d13
+ md5sums = 6c4edb108a0593bab7a556a6c9e8a012
+ md5sums = ec197a3d4300b09505d8cd8f1c18baf4
md5sums = cf87ad9db0bf279ddf9e5c1dce64a716
- md5sums = 531a3997ea28e8fc0f47e9e136dae332
- md5sums = 0a40eeb0da00cbb98820089de9efbd04
+ md5sums = 89b10711889f52ab0a386f37b4eb3212
+ md5sums = 8e6efbeafa440e3614518e4260b974e5
pkgname = deepin-wine-wechat
diff --git a/PKGBUILD b/PKGBUILD
index af34750767c2..4ccace75aa54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Vufa <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=3.5.0.46
+pkgver=3.6.0.18
wechat_installer=WeChatSetup
-deepinwechatver=3.4.0.38deepin4
+deepinwechatver=3.4.0.38deepin6
debpkgname="com.qq.weixin.deepin"
-pkgrel=3
+pkgrel=1
pkgdesc="Tencent WeChat on Deepin Wine(${debpkgname}) For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
@@ -20,13 +20,13 @@ _mirror_lib="https://community-packages.deepin.com/deepin/pool/main"
source=("$_mirror/appstore/pool/appstore/c/${debpkgname}/${debpkgname}_${deepinwechatver}_i386.deb"
"${wechat_installer}-${pkgver}.exe::https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
"$_mirror_lib/o/openldap/libldap-2.4-2_2.4.47+dfsg.4-1+eagle_i386.deb"
- "$_mirror_lib/c/cyrus-sasl2/libsasl2-2_2.1.27+dfsg-1+deb10u1_i386.deb"
+ "$_mirror_lib/c/cyrus-sasl2/libsasl2-2_2.1.27.1-1+dde_i386.deb"
"run.sh")
-md5sums=('940b59d57536a1e43bc9fc6f61d675ca'
- 'd81ce735e25cf79ac90bdc2c87020d13'
+md5sums=('6c4edb108a0593bab7a556a6c9e8a012'
+ 'ec197a3d4300b09505d8cd8f1c18baf4'
'cf87ad9db0bf279ddf9e5c1dce64a716'
- '531a3997ea28e8fc0f47e9e136dae332'
- '0a40eeb0da00cbb98820089de9efbd04')
+ '89b10711889f52ab0a386f37b4eb3212'
+ '8e6efbeafa440e3614518e4260b974e5')
build() {
msg "Extracting DPKG package ..."
@@ -35,7 +35,7 @@ build() {
tar -xvf data.tar.xz -C "${srcdir}/dpkgdir"
ar -x libldap-2.4-2_2.4.47+dfsg.4-1+eagle_i386.deb
tar -xvf data.tar.xz -C "${srcdir}/dpkgdir"
- ar -x libsasl2-2_2.1.27+dfsg-1+deb10u1_i386.deb
+ ar -x libsasl2-2_2.1.27.1-1+dde_i386.deb
tar -xvf data.tar.xz -C "${srcdir}/dpkgdir"
sed "s/\(Categories.*$\)/\1Network;/" -i "${srcdir}/dpkgdir/opt/apps/${debpkgname}/entries/applications/${debpkgname}.desktop"
sed "13s/WeChat.exe/wechat.exe/" -i "${srcdir}/dpkgdir/opt/apps/${debpkgname}/entries/applications/${debpkgname}.desktop"
@@ -70,5 +70,6 @@ package() {
install -m755 "${srcdir}/run.sh" "${pkgdir}/opt/apps/${debpkgname}/files/"
msg "Copying deepin lib32 files ..."
install -d "${pkgdir}/opt/apps/${debpkgname}/files/lib32"
- cp ${srcdir}/dpkgdir/usr/lib/i386-linux-gnu/{liblber-2.4.so.2,libldap-2.4.so.2,libldap_r-2.4.so.2,libsasl2.so.2} "${pkgdir}/opt/apps/${debpkgname}/files/lib32"
+ # cp ${srcdir}/dpkgdir/usr/lib/i386-linux-gnu/{liblber-2.4.so.2,libldap-2.4.so.2,libldap_r-2.4.so.2,libsasl2.so.2} "${pkgdir}/opt/apps/${debpkgname}/files/lib32"
+ cp ${srcdir}/dpkgdir/usr/lib/i386-linux-gnu/* "${pkgdir}/opt/apps/${debpkgname}/files/lib32"
}
diff --git a/README.md b/README.md
index 25b6f1782fab..98f515a6f9a3 100644
--- a/README.md
+++ b/README.md
@@ -6,7 +6,7 @@
<img src="https://img.shields.io/github/workflow/status/vufa/deepin-wine-wechat-arch/CI/action?logo=github&style=flat-square">
</a>
<a href="https://pc.weixin.qq.com/">
- <img src="https://img.shields.io/badge/WeChat-3.5.0.46-blue?style=flat-square&logo=wechat" alt="WeChat Version">
+ <img src="https://img.shields.io/badge/WeChat-3.6.0.18-blue?style=flat-square&logo=wechat" alt="WeChat Version">
</a>
<a href="https://aur.archlinux.org/packages/deepin-wine-wechat/">
<img src="https://img.shields.io/aur/version/deepin-wine-wechat?label=AUR&logo=arch-linux&style=flat-square" alt="AUR Version">
@@ -269,6 +269,7 @@ DEEPIN_WINE_SCALE=1.25
<details open>
<summary>2022</summary>
+* 2022-03-20 WeChat-3.6.0.18 3.4.0.38deepin6
* 2022-02-03 WeChat-3.5.0.46 3.4.0.38deepin4
* 2022-01-27 WeChat-3.5.0.46
* 2022-01-03 WeChat-3.4.5.45
diff --git a/run.sh b/run.sh
index 190ad972e98b..8b3dd9423d41 100755
--- a/run.sh
+++ b/run.sh
@@ -10,10 +10,10 @@
version_gt() { test "$(echo "$@" | tr " " "\n" | sort -V | head -n 1)" != "$1"; }
BOTTLENAME="Deepin-WeChat"
-APPVER="3.4.0.38deepin4"
+APPVER="3.4.0.38deepin6"
WINEPREFIX="$HOME/.deepinwine/$BOTTLENAME"
WECHAT_FONTS="$WINEPREFIX/drive_c/windows/Fonts"
-WECHAT_VER="3.5.0.46"
+WECHAT_VER="3.6.0.18"
EXEC_PATH="c:/Program Files/Tencent/WeChat/WeChat.exe"
EXEC_FILE="$WINEPREFIX/drive_c/Program Files/Tencent/WeChat/WeChat.exe"
START_SHELL_PATH="/opt/deepinwine/tools/run_v4.sh"