summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZoddo2023-07-11 23:50:05 +0200
committerZoddo2023-07-11 23:50:05 +0200
commit1eb634b66d813cfd4d26775daa0bdd33c029c9e7 (patch)
treecaf35d022c9b1c86d7242bd015ffe23e516ff885
parenta424cb5dc1a95441be45f8f65ee36b7c0ef00503 (diff)
downloadaur-1eb634b66d813cfd4d26775daa0bdd33c029c9e7.tar.gz
uppkg: discord 0.0.28
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rwxr-xr-xdiscord-launcher.sh2
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4cb66a01df17..bbd7c10ff344 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = discord_arch_electron
pkgdesc = Discord (popular voice + video app) using the system provided electron for increased security and performance
- pkgver = 0.0.27
+ pkgver = 0.0.28
pkgrel = 1
url = https://discord.com
arch = x86_64
@@ -13,12 +13,12 @@ pkgbase = discord_arch_electron
provides = discord
conflicts = discord
options = !strip
- source = https://dl.discordapp.net/apps/linux/0.0.27/discord-0.0.27.tar.gz
+ source = https://dl.discordapp.net/apps/linux/0.0.28/discord-0.0.28.tar.gz
source = discord-launcher.sh
source = LICENSE.html::https://discord.com/terms
source = OSS-LICENSES.html::https://discord.com/licenses
- sha512sums = 285a0119b4740402a3fa94d3679a52bc8d883413ee32187e90087960a4d34aaf316788d2708bbccafe3f995c2b99767b45bc4b7c731704ef887a8de1b3d3926f
- sha512sums = 6ca6dfbfb65bf4fec34aac4676f66bb602b5c4c3318fcc96236056d632c0c9af3c4eb775b491c2e722ed5de6a4c253677d6ee1a7be69e13045702fa3df8cf52f
+ sha512sums = 763fe47a0fb21a13e852bcc818d4e0e2ea4faf23fcfdc02fddfe06e8c829499e028e27b45d807d3b3edcc36788990f3f21c0460b9b8efc538b62f3b41aeb744d
+ sha512sums = b246e5be3b0f25d489aa208f493cfd0adfab0ace0d7fe49444be9434f11c0ad75c3a14bea70f92f94874e2d86aafd25e60472887935ab10dfec41b43f861dffc
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b209b6cf8bc2..141440254b4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=discord
_electron=electron
pkgname=${_pkgname}_arch_electron
-pkgver=0.0.27
+pkgver=0.0.28
pkgrel=1
pkgdesc="Discord (popular voice + video app) using the system provided electron for increased security and performance"
arch=('x86_64')
@@ -23,8 +23,8 @@ source=("https://dl.discordapp.net/apps/linux/$pkgver/$_pkgname-$pkgver.tar.gz"
'discord-launcher.sh'
'LICENSE.html::https://discord.com/terms'
'OSS-LICENSES.html::https://discord.com/licenses')
-sha512sums=('285a0119b4740402a3fa94d3679a52bc8d883413ee32187e90087960a4d34aaf316788d2708bbccafe3f995c2b99767b45bc4b7c731704ef887a8de1b3d3926f'
- '6ca6dfbfb65bf4fec34aac4676f66bb602b5c4c3318fcc96236056d632c0c9af3c4eb775b491c2e722ed5de6a4c253677d6ee1a7be69e13045702fa3df8cf52f'
+sha512sums=('763fe47a0fb21a13e852bcc818d4e0e2ea4faf23fcfdc02fddfe06e8c829499e028e27b45d807d3b3edcc36788990f3f21c0460b9b8efc538b62f3b41aeb744d'
+ 'b246e5be3b0f25d489aa208f493cfd0adfab0ace0d7fe49444be9434f11c0ad75c3a14bea70f92f94874e2d86aafd25e60472887935ab10dfec41b43f861dffc'
SKIP
SKIP)
diff --git a/discord-launcher.sh b/discord-launcher.sh
index 0ad60ab000c0..4f691c118598 100755
--- a/discord-launcher.sh
+++ b/discord-launcher.sh
@@ -13,7 +13,7 @@ if [[ -f "${flags_file}" ]]; then
fi
for line in "${MAPFILE[@]}"; do
- if [[ ! "${line}" =~ ^[[:space:]]*#.* ]]; then
+ if [[ ! "${line}" =~ ^[[:space:]]*#.* ]] && [[ -n "${line}" ]]; then
flags+=("${line}")
fi
done