summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Egorov2023-09-06 20:54:01 +0300
committerAlexander Egorov2023-09-06 20:54:01 +0300
commit64bdb0803dff0b4bbdd026e6d9b4a03605a7afb1 (patch)
tree0c1ef253ff857de049ed6f52114c2dc62a26067c
parent6d655b81652d39014a2411ee82208cdcafe23e9d (diff)
downloadaur-64bdb0803dff0b4bbdd026e6d9b4a03605a7afb1.tar.gz
Revert "All packages but SDK removed"
This reverts commit 6d655b81652d39014a2411ee82208cdcafe23e9d.
-rw-r--r--.SRCINFO46
-rw-r--r--PKGBUILD73
2 files changed, 113 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 897b223a6e23..28dfd680bfba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dotnet-core-6.0.110-bin
pkgver = 6.0.10.sdk110
- pkgrel = 2
+ pkgrel = 1
url = https://www.microsoft.com/net/core
arch = x86_64
arch = armv7h
@@ -14,15 +14,55 @@ pkgbase = dotnet-core-6.0.110-bin
source_aarch64 = https://download.visualstudio.microsoft.com/download/pr/1a0faccb-a85e-43b7-b2a6-78ee8b975855/572b91765e7db29d33887cf4b87bc86c/dotnet-sdk-6.0.110-linux-arm64.tar.gz
sha512sums_aarch64 = da312773a6def29612ea6898c489b86b2546e5e52c7c890134712c64fb3c0e52dfab88d8589858f9a9b39c3d2c9fc39406d6da251e3cfca399eb93df0c9ad5c6
+pkgname = aspnet-runtime-6.0.110-bin
+ pkgdesc = The ASP.NET Core runtime (binary)
+ depends = dotnet-runtime-6.0.110-bin
+ provides = aspnet-runtime=6.0.10
+ provides = aspnet-runtime-6.0.110
+ conflicts = aspnet-runtime=6.0.10
+ conflicts = aspnet-runtime-6.0.110
+
+pkgname = dotnet-runtime-6.0.110-bin
+ pkgdesc = The .NET Core runtime (binary)
+ depends = dotnet-host>=6.0.10
+ depends = gcc-libs
+ depends = glibc
+ depends = icu
+ depends = libgssapi_krb5.so
+ depends = libunwind
+ depends = zlib
+ depends = openssl
+ optdepends = lttng-ust: CoreCLR tracing
+ provides = dotnet-runtime=6.0.10
+ provides = dotnet-runtime-6.0.110
+ conflicts = dotnet-runtime=6.0.10
+ conflicts = dotnet-runtime-6.0.110
+
pkgname = dotnet-sdk-6.0.110-bin
pkgdesc = The .NET Core SDK (binary)
depends = glibc
depends = gcc-libs
- depends = dotnet-runtime-6.0-bin
- depends = dotnet-targeting-pack-6.0-bin
+ depends = dotnet-runtime-6.0.110-bin
+ depends = dotnet-targeting-pack-6.0.110-bin
depends = netstandard-targeting-pack
optdepends = aspnet-targeting-pack-bin: Build ASP.NET Core applications
provides = dotnet-sdk=6.0.10.sdk110
provides = dotnet-sdk-6.0.110
conflicts = dotnet-sdk=6.0.10.sdk110
conflicts = dotnet-sdk-6.0.110
+
+pkgname = dotnet-targeting-pack-6.0.110-bin
+ pkgdesc = The .NET Core targeting pack (binary)
+ depends = netstandard-targeting-pack
+ provides = dotnet-targeting-pack=6.0.10
+ provides = dotnet-targeting-pack-6.0.110
+ conflicts = dotnet-targeting-pack=6.0.10
+ conflicts = dotnet-targeting-pack-6.0.110
+
+pkgname = aspnet-targeting-pack-6.0.110-bin
+ pkgdesc = The ASP.NET Core targeting pack (binary)
+ depends = dotnet-targeting-pack-6.0.110-bin
+ provides = aspnet-targeting-pack=6.0.10
+ provides = aspnet-targeting-pack-6.0.110
+ conflicts = aspnet-targeting-pack=6.0.10
+ conflicts = aspnet-targeting-pack-6.0.110
diff --git a/PKGBUILD b/PKGBUILD
index 9d0f487ecd5e..6f492383be94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,18 @@
# Maintainer: Alexander Egorov <egoroff[at]gmail[dot]com>
+# armv7h and aarch64 Comaintainers needed
pkgbase=dotnet-core-6.0.110-bin
pkgname=(
+ 'aspnet-runtime-6.0.110-bin'
+ 'dotnet-runtime-6.0.110-bin'
'dotnet-sdk-6.0.110-bin'
+ 'dotnet-targeting-pack-6.0.110-bin'
+ 'aspnet-targeting-pack-6.0.110-bin'
)
pkgver=6.0.10.sdk110
+_runtimever=6.0.10
_sdkver=6.0.110
-pkgrel=2
+pkgrel=1
arch=('x86_64' 'armv7h' 'aarch64')
url='https://www.microsoft.com/net/core'
license=('MIT')
@@ -18,13 +24,45 @@ sha512sums_armv7h=('ed8a0a3c5edc42b6e82dc925c35ebd3ba0ddf94b98c97febb0f4ffa758b3
sha512sums_aarch64=('da312773a6def29612ea6898c489b86b2546e5e52c7c890134712c64fb3c0e52dfab88d8589858f9a9b39c3d2c9fc39406d6da251e3cfca399eb93df0c9ad5c6')
sha512sums_x86_64=('104da00b7bfe1f564723e2314d432ad9044cbfa9ad851bc99e06e730a032c6178e487a8bee3f28f8309a32652df0143301be0b827a0c7ad00614a1ce850495e8')
+package_dotnet-runtime-6.0.110-bin() {
+ pkgdesc='The .NET Core runtime (binary)'
+ depends=(
+ "dotnet-host>=${_runtimever}"
+ 'gcc-libs'
+ 'glibc'
+ 'icu'
+ 'libgssapi_krb5.so'
+ 'libunwind'
+ 'zlib'
+ 'openssl'
+ )
+ optdepends=('lttng-ust: CoreCLR tracing')
+ provides=("dotnet-runtime=${_runtimever}" "dotnet-runtime-6.0.110")
+ conflicts=("dotnet-runtime=${_runtimever}" "dotnet-runtime-6.0.110")
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.NETCore.App "${pkgdir}"/usr/share/dotnet/shared/
+ ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-runtime-6.0.110-bin
+}
+
+package_aspnet-runtime-6.0.110-bin() {
+ pkgdesc='The ASP.NET Core runtime (binary)'
+ depends=('dotnet-runtime-6.0.110-bin')
+ provides=("aspnet-runtime=${_runtimever}" "aspnet-runtime-6.0.110")
+ conflicts=("aspnet-runtime=${_runtimever}" "aspnet-runtime-6.0.110")
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet/shared,licenses}
+ cp -dr --no-preserve='ownership' shared/Microsoft.AspNetCore.App "${pkgdir}"/usr/share/dotnet/shared/
+ ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-runtime-6.0.110-bin
+}
+
package_dotnet-sdk-6.0.110-bin() {
pkgdesc='The .NET Core SDK (binary)'
depends=(
'glibc'
'gcc-libs'
- 'dotnet-runtime-6.0-bin'
- 'dotnet-targeting-pack-6.0-bin'
+ 'dotnet-runtime-6.0.110-bin'
+ 'dotnet-targeting-pack-6.0.110-bin'
'netstandard-targeting-pack')
optdepends=('aspnet-targeting-pack-bin: Build ASP.NET Core applications')
provides=("dotnet-sdk=${pkgver}" "dotnet-sdk-6.0.110")
@@ -35,3 +73,32 @@ package_dotnet-sdk-6.0.110-bin() {
ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-sdk-6.0.110-bin
}
+package_dotnet-targeting-pack-6.0.110-bin() {
+ pkgdesc='The .NET Core targeting pack (binary)'
+ depends=(
+ 'netstandard-targeting-pack'
+ )
+ provides=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-6.0.110)
+ conflicts=(dotnet-targeting-pack=${_runtimever} dotnet-targeting-pack-6.0.110)
+
+ if [ $CARCH = 'x86_64' ]; then msarch=x64;
+ elif [ $CARCH = 'armv7h' ]; then msarch=arm;
+ elif [ $CARCH = 'aarch64' ]; then msarch=arm64; fi
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
+ cp -dr --no-preserve='ownership' packs/Microsoft.NETCore.App.{Host.linux-${msarch},Ref} "${pkgdir}"/usr/share/dotnet/packs/
+ ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/dotnet-targeting-pack-6.0.110-bin
+}
+
+package_aspnet-targeting-pack-6.0.110-bin() {
+ pkgdesc='The ASP.NET Core targeting pack (binary)'
+ depends=(
+ 'dotnet-targeting-pack-6.0.110-bin'
+ )
+ provides=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-6.0.110)
+ conflicts=(aspnet-targeting-pack=${_runtimever} aspnet-targeting-pack-6.0.110)
+
+ install -dm 755 "${pkgdir}"/usr/share/{dotnet,dotnet/packs,licenses}
+ cp -dr --no-preserve='ownership' packs/Microsoft.AspNetCore.App.Ref "${pkgdir}"/usr/share/dotnet/packs/
+ ln -s dotnet-host-bin "${pkgdir}"/usr/share/licenses/aspnet-targeting-pack-6.0.110-bin
+}